Paris bindings for DOM Events

RESOLVED FIXED

Status

()

Core
DOM: Events
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: smaug, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

6 years ago
In the main thread it is probably easiest to make events to parent to window object,
similarly to XHR etc.
However, I don't know how XHR works in JS components where window isn't available.

I won't touch event implementations in workers.
(Reporter)

Comment 1

6 years ago
https://developer.mozilla.org/en/Mozilla/WebIDL_bindings doesn't seem to tell what happens if
GetParentObject returns null.


(Also, I don't quite understand the comments " returns the same object every time" ...
"For example, nsINode::GetParentObject returns the node's owner document".
Obviously owner document may change.)

("if your object can only be reflected into JS by creating it, not by retrieving it from somewhere" needs also some example)
If GetParentObject() returns null, then you get parented to the global of the object you're being gotten from.  To the extent that this can be a different object, you can get weird behavior across GC.  For components, returning null is fine, since there should be only one global involved.

> Obviously owner document may change.

We explicitly fix up the parenting when it changes, for nodes.  You _can_ do the same thing in other cases, but it's rather ... complicated.

> needs also some example

ImageData.  But I'll fill that out more.

I can't edit the article at the moment, unfortunately: devmo is not editable, and the import into the new wiki is corrupt (bug 775952).  Once that's sorted out, I'll update the docs with the above.
(Reporter)

Updated

6 years ago
Depends on: 777269
(Reporter)

Updated

6 years ago
Depends on: 777271
(Reporter)

Updated

6 years ago
Depends on: 780142

Updated

5 years ago
Blocks: 803844
Created attachment 680357 [details] [diff] [review]
Some API stuff

In case this is useful to you
(Reporter)

Comment 4

5 years ago
Maybe.
Though, I want probably autogenerate webidl->xpidl calls, or xpidl->webidl.

And yes, I've been über slow with this.
I need to do some smaller webidl changes first to get more familiar with it.
> Though, I want probably autogenerate webidl->xpidl calls,

Note that mccr8 is also working on something like that...
That's bug 785193. I haven't actually started writing any Python yet. I'm still experimenting with what it needs to look like. The next step is to start understanding the example class generator, as I think I'll want to use that the inject my glue code into.

Updated

5 years ago
Depends on: 822399

Updated

5 years ago
Duplicate of this bug: 517369
(Reporter)

Updated

5 years ago
Depends on: 839465

Updated

5 years ago
Blocks: 842498

Updated

5 years ago
Duplicate of this bug: 843496

Updated

5 years ago
Duplicate of this bug: 843501

Updated

5 years ago
Blocks: 637248
(Reporter)

Updated

5 years ago
Depends on: 847583
(Reporter)

Updated

5 years ago
Depends on: 847585
(Reporter)

Updated

5 years ago
Depends on: 847586
(Reporter)

Updated

5 years ago
Depends on: 847589
(Reporter)

Updated

5 years ago
Depends on: 847590
(Reporter)

Updated

5 years ago
Depends on: 847591
(Reporter)

Updated

5 years ago
Depends on: 847594
(Reporter)

Updated

5 years ago
Depends on: 847596
(Reporter)

Updated

5 years ago
Depends on: 847597
(Reporter)

Updated

5 years ago
Depends on: 847598
(Reporter)

Updated

5 years ago
Depends on: 847599
(Reporter)

Updated

5 years ago
Depends on: 847600
(Reporter)

Updated

5 years ago
Depends on: 847607
(Reporter)

Updated

5 years ago
Depends on: 847611
(Reporter)

Updated

5 years ago
Attachment #680357 - Attachment is obsolete: true

Updated

5 years ago
Depends on: 851073
(Reporter)

Updated

5 years ago
Depends on: 854573
(Reporter)

Updated

5 years ago
Depends on: 854999
(Reporter)

Updated

5 years ago
Depends on: 855091
(Reporter)

Updated

5 years ago
Depends on: 855110
(Reporter)

Updated

5 years ago
Depends on: 855241
(Reporter)

Updated

5 years ago
Depends on: 855486
(Reporter)

Updated

5 years ago
Depends on: 855522
(Reporter)

Updated

5 years ago
Depends on: 856351
(Reporter)

Updated

5 years ago
Depends on: 856364
(Reporter)

Updated

5 years ago
Depends on: 868232
(Reporter)

Comment 10

5 years ago
As far as I see, this is now fixed.
Assignee: bugs → nobody
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.