Makefile entry missing for MDPI phone

VERIFIED FIXED in Firefox 20

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: sriram, Assigned: sriram)

Tracking

unspecified
Firefox 22
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox20+ fixed, firefox21+ fixed, firefox22+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
A makefile entry for MDPI resource "ic_menu_new_tab.png" is missing. The file is available though. This would crash on MDPI GB phones, as it wouldn't be packed in the APK.
(Assignee)

Comment 1

5 years ago
Created attachment 716794 [details] [diff] [review]
Patch

Added to Makefile.
Attachment #716794 - Flags: review?(mark.finkle)
(Assignee)

Updated

5 years ago
tracking-firefox20: --- → ?
tracking-firefox21: --- → ?
Comment on attachment 716794 [details] [diff] [review]
Patch

Request approval for uplift
Attachment #716794 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 4

5 years ago
Comment on attachment 716794 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 838807, may be.
User impact if declined: Gingerbread MDPI phones will crash.
Testing completed (on m-c, etc.): Landed in m-i on 02/21
Risk to taking this patch (and alternatives if risky): None. File is present. Entry missing in Makefile.
String or UUID changes made by this patch: None.
Attachment #716794 - Flags: approval-mozilla-beta?
Attachment #716794 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/794d30acd4eb
Assignee: nobody → sriram
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
status-firefox20: --- → affected
status-firefox21: --- → affected
status-firefox22: --- → fixed
tracking-firefox20: ? → +
tracking-firefox21: ? → +
tracking-firefox22: --- → +
Comment on attachment 716794 [details] [diff] [review]
Patch

Glad this won't ship - approving for uplift.
Attachment #716794 - Flags: approval-mozilla-beta?
Attachment #716794 - Flags: approval-mozilla-beta+
Attachment #716794 - Flags: approval-mozilla-aurora?
Attachment #716794 - Flags: approval-mozilla-aurora+

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.