Intermittent test_filter_unread.js | ScriptTimeoutException: timed out

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: philor, Assigned: rwood)

Tracking

({intermittent-failure})

21 Branch
ARM
Gonk (Firefox OS)
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=19974740&tree=Services-Central
b2g_ics_armv7a_gecko_emulator services-central opt test marionette-webapi on 2013-02-21 20:34:30 PST for push 885cde564ff3
slave: talos-r3-fed-078

20:51:59     INFO -  ERROR: /home/cltbld/talos-slave/test/build/tests/marionette/tests/dom/sms/tests/marionette/test_filter_unread.js, runTest (marionette_test.MarionetteJSTestCase)
20:51:59     INFO -  ----------------------------------------------------------------------
20:51:59    ERROR -  Traceback (most recent call last):
20:51:59     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 213, in runTest
20:51:59     INFO -      results = self.marionette.execute_js_script(js, args, special_powers=True)
20:51:59     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 484, in execute_js_script
20:51:59     INFO -      scriptTimeout=script_timeout)
20:51:59     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 255, in _send_message
20:51:59     INFO -      self._handle_error(response)
20:51:59     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 304, in _handle_error
20:51:59    ERROR -      raise ScriptTimeoutException(message=message, status=status, stacktrace=stacktrace)
20:51:59    ERROR -  TEST-UNEXPECTED-FAIL | test_filter_unread.js | ScriptTimeoutException: timed out
20:51:59     INFO -  ----------------------------------------------------------------------
20:51:59     INFO -  Ran 1 test in 20.970s
20:51:59    ERROR -  FAILED (errors=1)
(Reporter)

Updated

6 years ago
Blocks: 854281
Comment hidden (Treeherder Robot)
The first log is just another case where we need a longer timeout for this test.  Can you fix that Rob?  The second log is a case of bug 859417, which we'll handle separately.
Assignee: nobody → rwood
(Assignee)

Comment 3

6 years ago
Created attachment 735174 [details] [diff] [review]
Increase test timeout

Fix intermittent orange caused by test timing out before simulator finishes SMS commands.
Attachment #735174 - Flags: review?(jgriffin)
(Assignee)

Comment 4

6 years ago
Comment on attachment 735174 [details] [diff] [review]
Increase test timeout

Ignore the attachment please, going to make one patch to increase timeout for all sms/telephony tests.
Attachment #735174 - Attachment is obsolete: true
Attachment #735174 - Flags: review?(jgriffin)
(Assignee)

Comment 5

6 years ago
Addressed in a patch in bug 841285.
Depends on: 841285
Comment hidden (Treeherder Robot)

Comment 7

5 years ago
(OrangeWFM bugs not touched for 2 months)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.