KOI8 HTML messages are decoded incorrectly

RESOLVED DUPLICATE of bug 594646

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 594646
5 years ago
5 years ago

People

(Reporter: Vladimir Morozov, Unassigned)

Tracking

22 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 716973 [details]
KOI8 Charset test

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130213 Firefox/21.0
Build ID: 20130213031137

Steps to reproduce:

Receive or compose message in HTML format in KOI8-RU charset.


Actual results:

Cyrillic symbols are displayed incorrectly. Looks like system tries to convert KOI8 to unicode and then display as single-byte charset.

Note: Text-only, Simplified HTML or in another single-byte charset (like 1251) messages are displayed correctly.


Expected results:

Cyrillic symbols shod be displayed in right way.
(Reporter)

Comment 1

5 years ago
Created attachment 716974 [details]
Screenshot of message
> Version: 22
>     <meta content="text/html; charset=KOI8-R" http-equiv="Content-Type">

Problem of bug 820335?
Do you see your problem with following?
>    <meta http-equiv="Content-Type" content="text/html; charset=KOI8-R">
When(from which Tb version) did your problem start to occur?

Note: Bug 594646 disappeared once, but has revived as reported to bug 820335. Because root cause of Bug 594646 is not resolved yet, bug 820335 was dup'ed to Bug 594646.
(Reporter)

Comment 3

5 years ago
Yes. It is because of Bug 594646
>> <meta content="text/html; charset=KOI8-R" http-equiv="Content-Type">
If i remove this line inside message - problem disappears. Even if http-equiv is on enother line there are no problems (as with windows-1251 charset - meta tag line is too long and is splitted on two lines).

I can't remember, when the problem appeared - may be a year ago. Usually messages comes with UTF-8, but, sometimes, if origin of first mail is IPad and then forwarded/responded in thunderbird - it keeps KOI8-R, but 
THUNDERBIRD INSERTS META TAG WHICH IT CAN'T PROCESS PROPERLY????
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594646
You need to log in before you can comment on or make changes to this bug.