Closed Bug 844243 Opened 8 years ago Closed 8 years ago

Installing a packaged app in which the mini-manifest app name is different than the webapp manifest app name is allowed, but should not be

Categories

(Core Graveyard :: DOM: Apps, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:tef+, firefox20 wontfix, firefox21 wontfix, firefox22 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

VERIFIED FIXED
mozilla22
blocking-b2g tef+
Tracking Status
firefox20 --- wontfix
firefox21 --- wontfix
firefox22 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- fixed

People

(Reporter: jsmith, Assigned: ferjm)

References

Details

(Keywords: regression)

Attachments

(1 file)

Device: Unagi
Build: B2G 18 2/22/2013

Steps:

1. Install a packaged app with the mini-manifest app name different than the webapp manifest app name

Expected:

We should fail to download with a MANIFEST_MISMATCH error.

Actual:

We successfully install the app with the app name from the mini-manifest. So we're apparently ignoring the webapp manifest's app name entirely.
I wonder if this is a regression from bug 834515.
Blocks: app-install
tracking-b2g18: --- → ?
Keywords: regression
See Also: → 844369
Blocks: 834515
Assignee: nobody → ferjmoreno
Attached patch v1Splinter Review
I am adding tests to bug 821589
Attachment #718544 - Flags: review?(fabrice)
Attachment #718544 - Flags: review?(fabrice) → review+
Duplicate of this bug: 844369
Dupe was a blocker, so this blocks for the same reason.
blocking-b2g: --- → tef?
tracking-b2g18: ? → ---
https://hg.mozilla.org/mozilla-central/rev/abffab917ab7
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
Keywords: verifyme
QA Contact: jsmith
blocking-b2g: tef? → tef+
Verified on 2/28 with the test case in this bug and the dupe of this bug.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.