Closed Bug 844349 Opened 7 years ago Closed 8 days ago

PDF Viewer has doubled/bad text rendering when High Contrast is enabled or "allow pages to set their own colors" is disabled and background is not white

Categories

(Firefox :: PDF Viewer, defect, P3)

19 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 74
Tracking Status
firefox74 --- fixed

People

(Reporter: joshudson, Assigned: emilio)

References

(Regressed 1 open bug)

Details

(Whiteboard: [pdfjs-c-feature])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

Opended a PDF document. Seems to be all PDF off the web that aren't scanned images affected.

System has high contrast setting enabled. Background text would be black and foreground green even if it was not set.


Actual results:

Tried to render with green text overstamped on black text on white background, resulting in completely unreadable text.


Expected results:

Either apply user-selected colors or don't. Never mix and match.
Component: Untriaged → PDF Viewer
Priority: -- → P4
Whiteboard: [pdfjs-c-feature]
Reproduces identically on Linux x64. Resetting platform to all.
OS: Windows 7 → All
Hardware: x86 → All
It seems for me that every pdf that has a text layer has a very similar problem that the text is displayed twice (i.e. the hiddel layer is rendered like a drop shadow). E.g. http://people.mozilla.org/~jdaggett/css3fontspresentation.pdf displays nearly unreadable while https://www.mozilla.org/foundation/donate_form.pdf is just fine in black on white high contrast (Win8).
Duplicate of this bug: 1071504

From the duplicate bug 1071504 comment 6:

That's not a double rendering -- that's a text layer for the selection and highlight operation. For some reason CSS styles to hide it are disabled in the high contrast mode.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: P4 → P3
Summary: PDF Viewer renders unviewable renderings when High Contrast is enabled or "allow pages to set their own colors" is disabled and background is not white → PDF Viewer has doubled/bad text rendering when High Contrast is enabled or "allow pages to set their own colors" is disabled and background is not white

Yeah, that's because we don't honor color for high contrast, but we should probably respect transparent, as we do for backgrounds...

Flags: needinfo?(emilio)

PDFJS uses it, for example to allow text selection. It's not great if it shows
on top of the actual PDF :-)

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/35612015dd2c
Do not ignore color: transparent in high contrast mode. r=jwatt
Status: ASSIGNED → RESOLVED
Closed: 8 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74
Regressions: 1610085
You need to log in before you can comment on or make changes to this bug.