www.tatrabanka.sk - Page doesn't load, redirects to URL with missing hostname

VERIFIED FIXED

Status

Tech Evangelism Graveyard
Other
P2
trivial
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: Julo, Assigned: Tristan Nitot)

Tracking

Details

(Whiteboard: [BANK][SYNTAX-HTML] CentralEurope, URL)

(Reporter)

Description

17 years ago
Using build 20010605.

Go http://www.tatrabanka.sk

Expected: page loads
Result:   dosn't

in location bar shows URL:
http://cgi-bin/web/app/index.jsp?BV_SessionID= etc....

If you correct ULR string to:

http://www.tatrabanka.sk/cgi-bin/web/app/index.jsp?BV_SessionID= etc....

page loads....
Works properly using IE 5 or Netscpe Navigator 4.77

Comment 1

17 years ago
The problem here is that mozilla doesn't correctly handle http:/ urls (as
compared to http:// urls).
This is a dupe.

Comment 2

17 years ago
This is a dupe of WONTFIX Bug 32966



*** This bug has been marked as a duplicate of 32966 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Reopening, assigning to evangelism. Quote Boris Zbarsky from bug 71952:

"URLs of the form http:/foo/bar (relative urls with protocol part) are
disallowed per RFC 2396.

See bug 32966 for details."


Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

17 years ago
reassign
Assignee: asa → bclary
Status: UNCONFIRMED → NEW
Component: Browser-General → Evangelism
Ever confirmed: true
QA Contact: doronr → zach

Comment 5

17 years ago
Resetting platform, os, priority and severity. We will get to this when we can.
Reporter you may wish to contact the site directly.  
Severity: normal → trivial
OS: Windows 2000 → All
Priority: -- → P5
Hardware: PC → All
Whiteboard: [SYNTAX-HTML]

Updated

17 years ago
Whiteboard: [SYNTAX-HTML] → [BANK][SYNTAX-HTML]

Updated

17 years ago
Assignee: bclary → nitot
QA Contact: zach → momoi

Comment 6

17 years ago
-> Intl

Updated

16 years ago
Component: Evangelism → European
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 7

16 years ago
Just checked and this works under 2001080703.  Fixed?
(Reporter)

Comment 8

16 years ago
Works for me too, thanks a lot.

Updated

16 years ago
Whiteboard: [BANK][SYNTAX-HTML] → [BANK][SYNTAX-HTML] CentralEurope

Comment 9

16 years ago
WFM, 20010816 WindowsME.

BTW this bug and bug 84291 are IMHO dupes.

Comment 10

16 years ago
*** Bug 84291 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
-> CentralEurope
Assignee: nitot → piskozub
Component: European → Central Europe
QA Contact: momoi → pali

Comment 12

16 years ago
With 20010801110 is http://www.tatrabanka.sk displayed correctly
But:
Reproducible: Always
Steps to Reproduce:
1. Point to URL https://moja.tatrabanka.sk/cgi-bin/ibanking/start/ibanking.jsp
2. Choose English language
3. Fill correct PID and password, press Enter
4. Error appears

isnt displayed. In location bar is showed URL
https://cgi-bin/ibanking/app/verify.jsp?BV_SessionID=

Another kind of redirecting?

Comment 13

16 years ago
Possibly. But as I am not able to login I cannot test this. What is the actual
error message?

Comment 14

16 years ago
Error message:

The requested URL could not be retrieved

While trying to retrieve the URL: cgi-bin.<host>.sk:443

The following error was encountered:
Unable to determine IP address from host name for cgi-bin.<host>.sk

The dnsserver returned:
DNS Domain 'cgi-bin.<host>.sk' is invalid: Host not found (authoritative).

This means that:

The cache was not able to resolve the hostname presented in the URL. 
 Check if the address is correct. 

<host> - site, from which is started Mozilla

Updated

16 years ago
Summary: Page doesn't load, redirects to URL with missing hostname → www.tatrabanka.sk - Page doesn't load, redirects to URL with missing hostname

Comment 15

16 years ago
Assigning to myself, according to my agreement with Jacek. (that I'll take care
of Czech/Slovak bugs)
--mondo
Assignee: piskozub → pali

Comment 16

16 years ago
changing status to assigned.

This bug will require assistance from someone with more official status
(@netscape.com or @mozilla.org), because this is a bank we are dealing with. I
have allready contacted them before. They replyed with (aproximate translation
from slovak):

"Netscape 6.0 still has some bug, because of that we do not consider enabling
our services with this browser at this time. We are discussing this problem though.

I can not give you more specific information now.

Regards

Lenka Salakova       <-- contact person
Elektronicke informacne centrum  
( ^^ translates as 'Electronical infornations center')
Tatra banka, a.s."

Their contact addres in this case should be: EIC@tatrabanka.sk
Don't know what to do with this bug though... 
Is there some agreed rule when contacting official bodies as banks?

--mondo
Status: NEW → ASSIGNED

Comment 17

16 years ago
Adding the right people to CC:

Kat, Tristan: Could you address the "contacting banks while not being
mozilla.org/Netscape afilliate" question that Pavol asked? I have the same
problem on some Polish bank evangelism bugs. Who is the right person to address
big corporations on Mozilla's behalf?

Comment 18

16 years ago
I think we at netscape evangelism group should evangelize financial 
institutions on behalf of all Gecko-based browsers, which includes 
Mozilla, Netscape, etc. Typically, banks want to have continued 
support for unblocking a browser. Being able to say that we are 
here to support you sometimes works better.
Re-assigning to Tristan.
Assignee: pali → nitot
Status: ASSIGNED → NEW

Updated

16 years ago
Blocks: 105898

Updated

16 years ago
No longer blocks: 105898

Updated

16 years ago
Blocks: 105898
(Assignee)

Comment 19

16 years ago
Accepting bug. Setting P2
Status: NEW → ASSIGNED
Priority: P5 → P2

Comment 20

16 years ago
OK. Today I've succesfully used Tatrabanka's internet banking with Mozilla
0.9.7. Everything works as should. 
Marking fixed.
(Strange thing is that they have Netscape logo as favicon... ;-) )
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Comment 21

16 years ago
erm.. I forgot: reporter, please verify and report back here

Comment 22

16 years ago
> Strange thing is that they have Netscape logo as favicon

It means they use the Netscape Web server. It sends its favicon as the default
if no other is placed in the root directory.
(Reporter)

Comment 23

16 years ago
Works now (build 2002012008), thanks.

Comment 24

16 years ago
Verifying fixed on the reporter's comment.
Status: RESOLVED → VERIFIED

Comment 25

15 years ago
-> other
Component: Europe: Central → Other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.