Non reliable textPath rendering at zero startOffset

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: j.tosovsky, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Open the attached example. There is a M letter rendered at the top of the circle path (start offset = 0.0%). It is centered (text-anchor = middle). The SVG content is auto-sized to fit the browser window.

The M letter is rendered only when the window size meets some rules (it seems to be a rounding issue). Otherwise it is not displayed at all. It can be easily reproduced during resizing the browser window. The M letter is periodically switched on/off.

It works fine in both Chrome and MSIE10.
Posted image A test case
Fixed on trunk if svg.text.css-frames.enabled is set.
Depends on: svgtext
Depends on: 839955
Works now that bug 655877 and dependants have landed.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.