Closed Bug 845278 Opened 7 years ago Closed 7 years ago

Regression caused by 843163. Callback missing

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:tef+, b2g18+ fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

RESOLVED FIXED
blocking-b2g tef+
Tracking Status
b2g18 + fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- fixed

People

(Reporter: borjasalguero, Assigned: jhammink)

References

Details

(Keywords: verifyme, Whiteboard: QARegressExclude)

Attachments

(1 file)

No description provided.
Attached file Pull Request
Attachment #718376 - Flags: review?(felash)
We left a var in the previous PR!! :S
Depends on: 843163
Assignee: nobody → fbsc
Attachment #718376 - Flags: review?(felash) → review?(fernando.campo)
Comment on attachment 718376 [details]
Pull Request

Fixing regression, no risk on merging (actually, the opposite!)
Attachment #718376 - Flags: review?(fernando.campo) → review+
Comment on attachment 718376 [details]
Pull Request

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Regression by 843163 
User impact if declined: SMS It's not working anymore
Testing completed: 
Risk to taking this patch (and alternatives if risky): None. We have to land this one after 843163 in order to have SMS working again & code ready for optimization PR.
String or UUID changes made by this patch:
Attachment #718376 - Flags: approval-gaia-v1?
Will wait for the answer to the question in bug 845278 before approving this.
Already answered Lukas :)
Already answered in bug 843163
Comment on attachment 718376 [details]
Pull Request

Approving to go along with bug 843163
Attachment #718376 - Flags: approval-gaia-v1? → approval-gaia-v1+
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.   If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval. Otherwise, if this is just a merge conflict, you might be able to resolve it with:
Loading commit times database
  git checkout v1-train
  git cherry-pick -x -m1 9be4d4bd72f001e60d9a0c787a1f36ccad5157f4
  <RESOLVE MERGE CONFLICTS>
  git commit
A chain of conflicts leads to Bug 837267, where I asked for approval.
This bug need tef+ because this is a regression to tef+ Bug 843163.
blocking-b2g: --- → tef?
v1-train: 74e15f1721f22035d41167fd4d4b9cd2dbffcfac
Duplicate of this bug: 850658
(tef+ per comment 12)
blocking-b2g: tef? → tef+
(In reply to Julien Wajsberg [:julienw] from comment #13)
> v1-train: 74e15f1721f22035d41167fd4d4b9cd2dbffcfac

I imagine uplift to v1.0.1 will also be difficult - can you help jhford uplift there as well?
Flags: needinfo?(felash)
I asked some help from Borja for Bug 844770 first.
Flags: needinfo?(felash)
Does not make sense to create a regression issue.
Flags: in-moztrap-
Flags: needinfo?(fbsc)
After checking I've realized that was uplifted to v1-train as well. Fixed.
Can you please provide steps to verify this fix - as we will blackbox test from the UI?
There is nothing to check here more than testing than SMS App is working as expected, due to this change it's tied to performance issues.
Whiteboard: QARegressExclude
Check that SMS ain't blowing up in smoketest.
Assignee: fbsc → jhammink
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.