[socorro-crashstats] per-OS topcrash list has wrong order and messed table headers

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: kairo, Assigned: rhelmer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Compare those two reports:

https://crash-stats-django.mozilla.org/topcrasher/products/Firefox/versions/19.0/date_range_type/report/crash_type/browser/os_name/Mac%20OS%20X?days=7

https://crash-stats.mozilla.com/topcrasher/byos/Firefox/19.0/Mac%20OS%20X/7/browser/report

Other than the URL for the former being somewhat complicated, it also misses one table header and the order of items isn't correct, it's not coming up sorted by topcrash rank (or amount of crashes on this OS).
(Assignee)

Comment 1

6 years ago
Looks like this bug is specifically related to filtering by OS.
Assignee: nobody → rhelmer
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Blocks: 749359
(Assignee)

Comment 3

6 years ago
(In reply to Robert Helmer [:rhelmer] from comment #2)
> peterbe r? https://github.com/mozilla/socorro-crashstats/pull/304

Oops please ignore, that's the wrong bug :/
(Assignee)

Comment 4

6 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #0)
> Compare those two reports:
> 
> https://crash-stats-django.mozilla.org/topcrasher/products/Firefox/versions/
> 19.0/date_range_type/report/crash_type/browser/os_name/Mac%20OS%20X?days=7
> 
> https://crash-stats.mozilla.com/topcrasher/byos/Firefox/19.0/Mac%20OS%20X/7/
> browser/report
> 
> Other than the URL for the former being somewhat complicated, it also misses
> one table header and the order of items isn't correct, it's not coming up
> sorted by topcrash rank (or amount of crashes on this OS).

OK I have the table header issue fixed, totally separate (it's just omitted from the template by mistake). The URL is now key/value so /versions/19.0, crash_type/browser and so on because some Socorro URLs were like this and some were not. We made this consistent throughout the site to make the code simpler and also to make input validation easier (we can use common regexes for URL routes and common validation code etc) and put in redirects for the URLs in the old site.

Working on the ranking order now, I believe the problem is a little deeper - I see fewer results for os-filtered pages than on the PHP app, which makes me think what's going on is that we're taking the full list and filtering out all the entries that don't match our OS, leaving holds in the ranking. This is wrong - we should be re-requesting the list from the middleware (it can do the OS filtering)
(Assignee)

Comment 5

6 years ago
(In reply to Robert Helmer [:rhelmer] from comment #4)
> Working on the ranking order now, I believe the problem is a little deeper -
> I see fewer results for os-filtered pages than on the PHP app, which makes
> me think what's going on is that we're taking the full list and filtering
> out all the entries that don't match our OS, leaving holds in the ranking.
> This is wrong - we should be re-requesting the list from the middleware (it
> can do the OS filtering)

Yeah looking at the mware URL I can see that this is the problem:

http://localhost:8080/bpapi/crashes/signatures/product/Firefox/version/19.0/crash_type/browser/end_date/2013-03-01/duration/168/limit/300/date_range_type/report/

The middleware should be doing the filtering here.
(Assignee)

Comment 6

6 years ago
Ok peterbe r? https://github.com/mozilla/socorro-crashstats/pull/307 

For real this time :)
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.