Closed Bug 749359 Opened 8 years ago Closed 7 years ago

[tracker] deploy Django webapp on crash-stats.m.o

Categories

(Socorro :: General, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: lonnen, Assigned: lonnen)

References

Details

It's time to remake the webapp as a Django site.

The plan is to reimplement pages in Django, serving them from Django instead of PHP as they become ready, until the whole webapp is being served from django. Then we can delete the PHP webapp.

Use this bug to track individual pieces of the rewrite.
Depends on: 650904
Depends on: 787240
Depends on: 788003
Depends on: 788062
No longer depends on: 788062
Blocks: 789394
Depends on: 788082
Depends on: 788063
No longer depends on: 650904
Depends on: 803183
Depends on: 805323
Depends on: 804292
Depends on: 822484
Blocks: 797400
Blocks: 788063
No longer depends on: 788063
Blocks: 804684
Blocks: 788053
Depends on: 844962
Blocks: 788048
Blocks: 804253
Depends on: 778863
Blocks: 812024
Blocks: 803607
Blocks: 768735
Depends on: 799690
Depends on: 845439
Depends on: 843867
Blocks: 789334
Blocks: 797557
Depends on: 842720
Depends on: 809623
Blocks: 805107
Blocks: 844793
Blocks: 804292
No longer depends on: 804292
Blocks: 788061
Blocks: 788062
No longer depends on: 788082
Blocks: 787240
No longer depends on: 787240
Depends on: 846815
Depends on: 846376
Depends on: 847294
Depends on: 847293
Depends on: 847281
No longer blocks: 788053
Depends on: 788053
No longer depends on: 809623
If bug 788048 is about correlations not working at all in socorro-crashstats, I'd see that as a blocker of deployment as primary UI, not as a dependency on it.

Bug 778863, as eager as I am to have it, is the other way round, from what I can tell: It's already a bug on PHP, so not a blocker, but we'll only solve it on django, so a dependeny.

I'd see bug 850985 as blocker, but that WFM right now.

The sorting bugs all seem to be blockers to me: bug 850988 (only soft blocker), bug 850991, bug 845439 (I see that one is marked fixed, yay).

Bug 848497 is probably bad enough to warrant blocking as well.

Bug 849897 is a blocker for a numbers of devs.


And bug 821179 is a blocker of course (same as bug 844140, btw?), but I guess that blocks bug 788053 from working anyhow.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #1)
> If bug 788048 is about correlations not working at all in
> socorro-crashstats, I'd see that as a blocker of deployment as primary UI,
> not as a dependency on it.

Correlations has been intermittently busted in general for a while due to bug 836671, have you seen specific cases where it works on old crash-stats and not new? Please add to that bug if so and we can block on it (I have a hard time reproducing correlations report behavior in general...)

Right now correlations are pulled via the old PHP app, so it should be working the same.
Depends on: 850988
Depends on: 850991
Depends on: 848497
No longer depends on: 778863
Depends on: 849897
Depends on: 844140
Blocks: 778863
(In reply to Robert Helmer [:rhelmer] from comment #2)
> Correlations has been intermittently busted in general for a while due to
> bug 836671, have you seen specific cases where it works on old crash-stats
> and not new?

I've seen that (i.e. working on PHP and not on django) at least when I tried in one case, but I'll need to take another look and find specific cases to link - of course, those usually are only trustworthy to be reproducible as long as it's the same day of data we're looking at...
Blocks: 799690
No longer depends on: 799690
Depends on: 855382
Depends on: 855384
No longer blocks: 788048
Depends on: 788048
Depends on: 855392
Depends on: 865481
Depends on: 865485
Depends on: 867556
No longer depends on: 865485
Depends on: 868882
Blocks: 875990
Blocks: 875992
No longer blocks: 875990
Filed blocker bug 875992 for things that don't block turning django on, but do block turning PHP off (just correlations right now)
Changing the summary to avoid confusion - we can deploy the django app without turning off PHP, items that blocks turning off PHP are now in bug 875992
Summary: [tracker] Migrate PHP webapp to Django → [tracker] deploy Django webapp on crash-stats.m.o
Depends on: 879359
Depends on: 881615
Depends on: 881616
Depends on: 881617
Depends on: 881623
Depends on: 881622
Depends on: 881621
Depends on: 881625
Depends on: 881630
Depends on: 881629
Depends on: 881627
Depends on: 881632
Depends on: 881709
No longer depends on: 881622
No longer depends on: 881623
Depends on: 881623
No longer depends on: 881621
Depends on: 882489
No longer depends on: 881623
Depends on: 883172
No longer depends on: 881629
No longer depends on: 885871
We are ready to ship. Just need the php domain set up - bug 886604.
Depends on: 886604
Blocks: 884623
Depends on: 887900
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.