'Component is not available' nsIActivityManager::removeActivity from autosync.js

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: wsmwk, Unassigned)

Tracking

Trunk
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
recent trunk (but not today's)

I don't know what this is or why I am getting it.
Perhaps started when I added chat account?

Error: [Exception... "'Component is not available' when calling method: [nsIActivityManager::removeActivity]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource:///modules/activity/autosync.js :: <TOP_LEVEL> :: line 203"  data: no]
Source File: resource:///modules/activity/autosync.js
Line: 203

Comment 1

4 years ago
That's strange, because that removeActivity is enclosed in a try catch block, so it should eat exceptions. Do you still get it?
(Reporter)

Comment 2

3 years ago
(In reply to :aceman from comment #1)
> That's strange, because that removeActivity is enclosed in a try catch
> block, so it should eat exceptions. 
> ..
> Do you still get it?

no (but I don't normally use tb chat)

but now I see 
Error: uncaught exception: No connected MUC enabled account!
Source File: chrome://messenger/content/chat/chat-messenger-overlay.js
Line: 759
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.