If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Hide spellchecker pref

VERIFIED FIXED in mozilla1.0

Status

MailNews Core
Composition
--
minor
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: BenB, Assigned: BenB)

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

17 years ago
If the spellchecker is not installed, the pref checkbox is disabled. It should
be hidden. (Ideally not exist at all, but that's another thing.)
I remember reviewing the patch to make it so the UI was disabled when the spell 
checker wasn't installed.

see bug #65677

see 
http://lxr.mozilla.org/seamonkey/source/mailnews/compose/prefs/resources/content
/pref-composing_messages.xul#51


Comment 2

17 years ago
change qa contact->esther 
QA Contact: sheelar → esther
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.3

Comment 3

17 years ago
I think if the spell checker is not installed, the UI should let you know how to
install it. I was about to report the missing spell-checker as a bug! I think
it's good to let the user know the possibility of a spell-checker exists when
it's missing. 
(Assignee)

Comment 4

17 years ago
Just that none exists, at least no open-source one.
*** Bug 88937 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

16 years ago
Attaching fix.

Seth, please review.
Keywords: review
(Assignee)

Comment 7

16 years ago
Created attachment 41261 [details] [diff] [review]
Fix, version 1.

Comment 8

16 years ago
Makes no sense to have it disabled if it's not possible to enable it (at least
not for Mozilla).

r=hwaara

Comment 9

16 years ago
*shrug* i'm working on getting amaya's spellchecker working in moz, it'll be 
harder for me to find the thing to enable if i can't see it.
(Assignee)

Comment 10

16 years ago
timeless, check the patch to see where the code is :). I believe that this is
the right thing to do, even if we have an open-source spellchecker. We don't
have UI for Mailnews either, if it isn't installed.
sr=sspitzer

please make sure to that it still shows up when there is a spell checker.
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Updated

16 years ago
Keywords: review
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 12

16 years ago
What's the status on an open-source spellchecker?  I don't have one installed,
but the pref is still showing up selected, but greyed.

Comment 13

16 years ago
Created attachment 55209 [details]
Screenshot of behavior
(Assignee)

Comment 14

16 years ago
ahhhh

Comment 15

16 years ago
1. nothing in this bug indicates benb committed the patch
2. i'm currently employed in other endeavors and my spellchecker impl is on my
home pc collecting dust.  Afaik there is no currently active open source
activity on a spell checker.
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.7

Comment 16

16 years ago
I think I'm in disagreement with this fix.  Dunno if anyone else cares
what I think, but.  I think it's important to let people know that mozilla
knows how to do spell checking, even if not internally.  When I wanted to
know if mozilla could do it, I looked at the prefs.  When I saw the disabled
pref, I looked into why it was disabled, rather than just throwing my hands
up and thinking "mozilla sucks that it doesn't know how to do that".

AFA open-source spell checkers, what about ispell?  Or aspell/pspell 
(http://aspell.sourceforge.net/)  Perhaps we could just get the aspell
library and just put it into mozilla?  Or at least make it know how to
use it internally via linking against that library...
> AFA open-source spell checkers, what about ispell?  Or aspell/pspell 

http://www.mozilla.org.uk/docs/spell-checker-faq.html .

Gerv
(Assignee)

Updated

16 years ago
Keywords: mozilla1.0

Comment 18

16 years ago
*** Bug 114280 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
This (simple but effective) patch has an r and sr, but hasn't been checked in.
If anyone knows the reason it hasn't been checked in please add it in a comment 
or a status whiteboard update.  Is it because some future Netscape spell 
checker xpi might work with the moz 0.9.7 release and this patch would still 
hide the pref?
It hasn't been checked in because no-one's got around to it. BenB?

Gerv
(Assignee)

Comment 21

16 years ago
My fault. Was not high on my priv list.

Seth, can I still check this in 0.9.8 (because of the perf etc. focus)? (I will
make sure that the stuff still works.)
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.8

Updated

16 years ago
Blocks: 119232

Comment 22

16 years ago
status for the patch attachment should perhaps be updated. (r= and sr=?)
patch should perhaps be checked in if it has not rotted.
(Assignee)

Comment 23

16 years ago
Comment on attachment 41261 [details] [diff] [review]
Fix, version 1.

It has been rotted, but it is easy to adapt. Not sure, if I need new reviews
for that.
Attachment #41261 - Flags: superreview+
Attachment #41261 - Flags: review+

Comment 24

16 years ago
If the code change is exactly the same, you don't need new review.
cc'ing varada for review...
(Assignee)

Comment 26

16 years ago
Created attachment 74356 [details] [diff] [review]
Fix, version 2

It got even more trivial...

Sorry for the checkin delay. Will check in at least with my next checkin.
Attachment #41261 - Attachment is obsolete: true
Comment on attachment 74356 [details] [diff] [review]
Fix, version 2

r=db48x
Attachment #74356 - Flags: review+
R=ducarroz (as module owner)
(Assignee)

Updated

16 years ago
Severity: normal → minor
Target Milestone: mozilla0.9.8 → mozilla1.0

Comment 29

16 years ago
Comment on attachment 74356 [details] [diff] [review]
Fix, version 2

sr=bienvenu
Attachment #74356 - Flags: superreview+

Comment 30

16 years ago
Comment on attachment 74356 [details] [diff] [review]
Fix, version 2

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #74356 - Flags: approval+
(Assignee)

Comment 31

16 years ago
Checked in. Sorry that it took so long. Thanks for the reviews/a.

I had no way to test it with the NS spellchecker installed. But the fix is
trivial enough :).
Severity: minor → normal
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Target Milestone: mozilla1.0 → mozilla0.9.8
(Assignee)

Updated

16 years ago
Severity: normal → minor
Target Milestone: mozilla0.9.8 → mozilla1.0

Comment 32

16 years ago
Using build 20020328 on winxp and linux this is fixed.  However on Mac, without
a spell checker installed I still see this preference and it's not disabled,
also the Spell button is on the toolbar and in the options menu in an enabled
state. Clicking on any of these result in nothing happening.   Reopening for the
Mac OS9.1, if I should write a new bug let me know
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 33

16 years ago
This sounds like unrelated local horkage to me, esp. since I haven't touched the
Composer toolbar button. Doesn't the mac have some central registry? Make sure
that there are no trails of an old / other spellchecker installation accessible.

Comment 34

16 years ago
ben, can you resolve this or mark the landed patch as obsolete so this doesn't
look like an approved patch waiting to land? Thanks.
(Assignee)

Comment 35

16 years ago
o-kay...
I believe this is fixed. See my last comment.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 36

16 years ago
I will check the mac with a clean installation and update.

Comment 37

16 years ago
I'll ask Grace if she can check the Mac on a clean install. 

Comment 38

16 years ago
Grace ran the test on a Mac with no previous mozilla app.  However Communicator
4.7x was installed and may have had a spellchecker installed.  When installing
the latest build without spell check she still saw the spell button and
preference but they did nothing.  If Ben's statement is true that Mac may have a
central registry and any app with a spellchecker will cause these toolbar
buttons and preferences to display then I can't test this on the Mac and will
verify for win and linux.  This may not be an issue for Mac users if most of the
apps they install have spellcheckers.  
Status: RESOLVED → VERIFIED
(Assignee)

Comment 39

16 years ago
> When installing the latest build without spell check she still saw the spell
> button and preference but they did nothing.

Most likely, this was true even before this change. Thanks for vrfying.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.