5x slowdown in redrawing SVG between FF16 and FF19

RESOLVED FIXED

Status

()

Core
SVG
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: RichH, Unassigned)

Tracking

({perf, regression})

18 Branch
x86_64
Windows 7
perf, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox21 affected, firefox22 fixed)

Details

(Whiteboard: [external-report])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 719324 [details]
svgrerender.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.97 Safari/537.22

Steps to reproduce:

I've witnessed a host of SVG rendering slowdowns since upgrading FF16 to FF19 on Windows 7 and OSX with all add-ons disabled. The worst slowdown appears to be due to removing SVG elements.

To reproduce this run the attached html.


Actual results:

On my Win 7 box. The page load times are as follows 

(1) If you paste the URL into a fresh FF 19 tab: ~4 seconds
(2) Hit reload on the FF19 tab: ~20 seconds

For reference ...
IE 9 new tab: ~2 seconds
IE 9 reload tab: ~2 seconds



Expected results:

In FF 16 pasting the URL into a new tab (1) and hitting reload (2) rendered in the same time. In FF 19 there is a 5x slowdown. 

This slowdown has also been exhibited in my applications when I am destroying svg elements, etc (i.e. not just while loading a new page). This has negatively affected various situations, such as D3 brushing, with much smaller datasets.

Updated

5 years ago
Component: Untriaged → SVG
Product: Firefox → Core

Updated

5 years ago
Attachment #719324 - Attachment mime type: text/plain → text/html

Comment 1

5 years ago
It's not so easy to observe the slowdown, I would say it's pretty reproducible when the user is reloading the tab with the testcase and switching to another tab, Firefox hangs (repeat these steps if need be).

A possible regression range, someone needs to confirm:
m-c
good=2012-10-07
bad=2012-10-08
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ecd4c4304219&tochange=9738e5a0190a
Keywords: regressionwindow-wanted
Keywords: perf

Comment 2

5 years ago
I got a different regression range.

Regression window with STR of Comment#0(reload page(F5)) is as follows:

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/b274e8e3479f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928160219
Bad:
http://hg.mozilla.org/mozilla-central/rev/b62b229a4d41
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928161018
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b274e8e3479f&tochange=b62b229a4d41


Regression window(m-c)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9f476b4ac1e1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928040137
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6b58397ad735
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928042236
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9f476b4ac1e1&tochange=6b58397ad735
That range makes more sense, since bug 539356 is a very likely culprit. Probably the issues here are covered by some of the follow-up bugs that have yet to be fixed, most notably bug 827915 and it's sub bugs.
Blocks: 539356
Keywords: regressionwindow-wanted

Comment 5

5 years ago
The try server build does NOT seem to fix the problem ..., I can still reproduce the slowness when reload page.
Thanks for checking; I was just curious.

Updated

5 years ago
Keywords: regression

Updated

5 years ago
Version: 19 Branch → 18 Branch
Can you retest with latest nightly please?

Comment 8

5 years ago
Fixed window(m-c):
Bad:
http://hg.mozilla.org/mozilla-central/rev/763d675d2ab9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130302 Firefox/22.0 ID:20130302190549
Good:
http://hg.mozilla.org/mozilla-central/rev/8b0c6e0bbd0f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130302 Firefox/22.0 ID:20130302203751
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=763d675d2ab9&tochange=8b0c6e0bbd0f

Fixed window(m-i):
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6ae1781d5e18
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130302 Firefox/22.0 ID:20130302023750
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b0857123e281
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130302 Firefox/22.0 ID:20130302092149
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6ae1781d5e18&tochange=b0857123e281


Fixed by: Bug 845526

Updated

5 years ago
status-firefox21: --- → affected
status-firefox22: --- → fixed

Updated

5 years ago
Depends on: 845526
Awesome, thanks for tracking down the fixing bug!!
Fixed by bug 845526 per comment 8, then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 11

5 years ago
I no longer see the continuous performance decrease running in Nightly!

Computational performance in the model and rendering the view is still slower
than FF v16.02 but the most serious performance regression appears to be fixed.


Firefox 23.0a1 (2013-04-30)
model+graphics
steps/s           frames/s
----------------------------
46.0                25.5
48.6                28.0
47.7                29.5
50.7                33.5


Firefox 16.0.2
model+graphics
steps/s           frames/s
----------------------------
104.2               32.0
110.5               34.5
98.4                33.0
100.1               34.0

Comment 12

5 years ago
Benchmarks reported in previous comment were testing this Molecular Dynamics simulation


http://lab.dev.concord.org/examples/interactives/interactives.html#interactives/benchmarks/2-oil-and-water-shake.json
Whiteboard: [external-report]
You need to log in before you can comment on or make changes to this bug.