Defect - On first install win8 prompt does not have firefox listed

VERIFIED FIXED in Firefox 23

Status

P1
normal
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: jimm, Assigned: bbondy)

Tracking

Trunk
Firefox 23
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=defect c=Install_and_setup u=browser_user p=3)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
STR:

Fresh machine, never installed before.

1) install firefox
2) open firefox desktop - get prompted to set fx as default, click yes

result: two prompts, one centered on the browser window, and one flyout. The centered dialog lists IE and app store without firefox. Clicking on the flyout you get another popup that lists ie and firefox.

Updated

6 years ago
Blocks: 841214
(Assignee)

Updated

6 years ago
Whiteboard: metro-mvp? → metro-mvp? p=3

Updated

6 years ago
Flags: needinfo?(asa)

Comment 1

6 years ago
I haven't been able to reproduce this. I uninstalled Firefox, setting IE as the default and then installed a new nightly from m-c and things seemed to work just fine. Any suggestions?
Flags: needinfo?(asa)
(Reporter)

Comment 2

6 years ago
(In reply to Asa Dotzler [:asa] from comment #1)
> I haven't been able to reproduce this. I uninstalled Firefox, setting IE as
> the default and then installed a new nightly from m-c and things seemed to
> work just fine. Any suggestions?

It happens for fresh installs on new machines. I think uninstalling all versions of firefox and then installing fresh might reproduce as well.
(Reporter)

Updated

6 years ago
Component: General → Shell
(Assignee)

Comment 3

6 years ago
Jim is it possible that there was something wrong with your machine? I tried with a fresh VM and Firefox is listed in both the Windows flyout and also the prompt once you start the browser.  Perhaps it's an intermittent problem?
Flags: needinfo?(jmathies)
(Reporter)

Comment 4

6 years ago
(In reply to Brian R. Bondy [:bbondy] from comment #3)
> Jim is it possible that there was something wrong with your machine? I tried
> with a fresh VM and Firefox is listed in both the Windows flyout and also
> the prompt once you start the browser.  Perhaps it's an intermittent problem?

I experienced this on the very first install on a brand new surface pro. I can't wipe that particular device to reproduce though. We might be able to replicate by working up a registry script that wipes all remnants of fx off a device.
Flags: needinfo?(jmathies)
(Assignee)

Comment 5

6 years ago
I think it might be an intermittent problem with the registration not happening fast enough in the background before the prompt is shown.  Maybe whatever triggers Win8 to prompt it we should do after the default browser registration.
(Assignee)

Comment 6

6 years ago
Suggestion for jimm for it5. If you can reproduce with a registry script then try Comment 5 fix.  Flagging Marco for whiteboard fields for defect in it5.
Blocks: 831497, 850809
No longer blocks: 841214
Flags: needinfo?(mmucci)
Moving to Iteration #5 for consideration as a defect.
Flags: needinfo?(mmucci)
Priority: -- → P1
QA Contact: jbecerra
Summary: On first install win8 prompt does not have firefox listed → Defect - On first install win8 prompt does not have firefox listed
Whiteboard: metro-mvp? p=3 → feature=defect c=Install_and_setup u=browser_user p=3
(Assignee)

Updated

6 years ago
Assignee: nobody → netzen

Updated

6 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 8

6 years ago
Created attachment 734399 [details] [diff] [review]
Patch v1.

I think the thing that makes that first prompt come up is the calls to: `CleanupMetroBrowserHandlerValues` && `AddMetroBrowserHandlerValues`.

I verified and the registry key entry that makes Firefox popup in that menu is: HKEY_CURRENT_USER\Software\Clients\StartMenuInternet\FIREFOX.EXE\Capabilities\URLAssociations\http set to FirefoxURL) 
Which is set in `SetStartMenuInternet`.

So although I can't reproduce, I think the fix here is to ensure that we call `SetStartMenuInternet` before calling `CleanupMetroBrowserHandlerValues` && `AddMetroBrowserHandlerValues`.
It doesn't matter for updates and setting default after the first install because the `SetStartMenuInternet` regkeys would already exist.  That explains why this was only found on a fresh machine.

By the way I was testing with a brand new VM when I worked on this and couldn't reproduce but it makes sense that it could happen on some different machines.
Attachment #734399 - Flags: review?(jmathies)
(Reporter)

Comment 9

6 years ago
Comment on attachment 734399 [details] [diff] [review]
Patch v1.

I've still got that 64GB surface sitting around that I've reset, I'll break that out and take the nightly off this for a spin.
Attachment #734399 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/13943daf18f8
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Flags: needinfo?(mozbugs.retornam)
Mozilla/5.0 (Windows NT 6.2; rv:23.0) Gecko/20130414 Firefox/23.0

Couldn't reproduce the initial issue, but made sure that the flow works as expected on two Win 8 machines. Prompt displayed - Nightly set to default.
Status: RESOLVED → VERIFIED
Flags: needinfo?(mozbugs.retornam)
Went through the following "Defect" for iteration #6 testing. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-04-30-03-09-41-mozilla-central/

Installed Firefox Metro on the following Windows 8 machines:
- Windows 8 x64 & Windows 8 x86 on fresh VM snapshots
- Windows 8 x64 on a desktop
- Windows 8 x64 on a touch ultrabook

Used the following tests on the above machines:

- Installed Firefox Metro using the "Standard" selection and ensured "Nightly" appeared in the "Default" list
- Installed Firefox Metro using the "Custom" selection and ensured "Nightly" appeared in the "Default" list
- Ensured that the entire installation flows worked as expected
- Ensured that once "Nightly" is selected, that it's set as the default browser

Couldn't reproduce the original issue (went through about 3 installations on each of the list machines)
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130825030201
Built from http://hg.mozilla.org/mozilla-central/rev/01576441bdc6

WFM
Tested on windows 8 using latest nightly for iteration-12. I didn't see any issue for two different machines.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.