must kill -9 process after Java2 Plugin is installed

VERIFIED DUPLICATE of bug 84896

Status

Core Graveyard
Java: OJI
P3
normal
VERIFIED DUPLICATE of bug 84896
17 years ago
7 years ago

People

(Reporter: Robert Spalek, Assigned: dbragg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Mozilla 0.9.1+ 2001060721

After I've successfully installed Java2 plugin, I quit the browser to take
changes into account.  Unfortunately a process hangs up and I have to kill it
manually, else Mozilla tells me that the installation did not finish when next
started.

Comment 1

17 years ago
i have seen this...confirming. correcting component:OJI
Assignee: av → edburns
Component: Plug-ins → OJI

Comment 2

17 years ago
Installation.  Over to Xiaobin.
Assignee: edburns → xiaobin.lu
Priority: -- → P3

Comment 3

17 years ago
I'm having this same problem. 

When I go to a page that requires Java, it will kick open the "You need a 
Plugin!" page. So I download the Java plugin, and it installs very happily. I 
close Mozilla, restart it, and I get a dialog:

"The program must close to allow a previous installation attempt to complete. 
Please restart."

If I do a ps aux, I can see /usr/local/mozilla/xpicleanup is running, and won't 
die. 

Once this happens, I can't restart Mozilla unless it is reinstalled.

Comment 4

17 years ago
sorry...took a while to 'confirm' this bug..this does really happen ..even on 
windows for me too. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
corrected typo in summary
Summary: must kill -9 process adter Java2 Plugin is installed → must kill -9 process after Java2 Plugin is installed

Comment 6

17 years ago
I am really think it is a XPInstaller issue. Over to XpInstaller comp.
Assignee: xiaobin.lu → ssu

Comment 7

17 years ago
Really annoying bug... I've also heard people talking about deleting one
"xpicleanup.dat" file for mozilla to work again... except that java doesn't work
after that.

Comment 8

17 years ago
What's happening here is that once you install Java, the installer spins off 
xpicleanup at shutdown of the browser if there are files that were in use and 
therefore could not be replaced right away.  Xpicleanup is responsible for 
finishing the replacing process once the browser has quit.  If there are still 
files in use by other apps (or if some were marked readonly), then xpicleanup 
will stick around until it's finished.

Yes, there are some problems with xpicleanup that we're going to address.  In 
the meantime, can you attach the xpicleanup.dat file to this bug? it should be 
in the same dir as xpicleanup and mozilla.  This .dat file contains information 
on what files still need to be resolved (replaced/deleted/moved/etc...).  It 
will tell us which file(s) it's having problems with.

Comment 9

17 years ago
Created attachment 40323 [details]
my xpicleanup.dat file from shortly after java plugin install

Comment 10

17 years ago
There's my xpiclenup.dat file which I copied to my home dir right after the java
plugin installed successfully and then the browser failed to restart because it
was "still running"
I may be able to get a couple other people's files and will attach them in due
course.

Comment 11

17 years ago
from looking at the .dat file, it looks like can't delete:
  /home/vanbalen/tmp/xpinstall.sh

do you know if that file is readonly?  In any case you should be able to simple 
delete xpicleanup.dat and you should be good to go.

As to the problem that it still tells you that you need the java plugin after 
you've installed, what's the url to the java plugin that you have been trying to 
install?

Comment 12

17 years ago
I don't have problems getting the plugin to work, I simply install it off
http://home.netscape.com/plugins/jvm.html and them kill -HUP the xpicleanup
process before restarting the browser and then the plugin works.

I find this annoying because I shouldn't have to kill a process in order for my
browser to work... if the xpicleanup process is going to take so long, there
should be some kind of progress bar telling me that it's still working so I know
not to try to restart the browser yet. Of course, I can kill the process without
any apparent adverse consequences so maybe it shouldn't be running anyway?

The problem I mentioned with the plugin not working was reported by a couple
people on the debian-user mailing list who had installed 0.9.1 from
debian-unstable. I think they're installing the plugin off java.sun.com though.

Comment 13

17 years ago
I think this is a dupe of another bug already dealilng with xpicleanup.  I can't 
find the bug right now.

Dave, you are correct, you shouldn't need to do anything for the browser to 
work.  We're rethinking the way xpicleanup is implemented.
Assignee: ssu → dbragg

Comment 14

17 years ago
Oh, sorry about the spam but /home/vanbalen/tmp/xpinstall.sh is gone now so I
guess it got deleted between the time I copied the file and when I killed the
process.

Updated

17 years ago
Blocks: 89792

Comment 15

17 years ago
It actually goes away if you wait long enough (when I tried, seemed like a
minute or less).

Comment 16

17 years ago
Yes, I tried waiting also. I kept running the browser until it finally worked...
still didn't get the java plugin recognized (stopped working a few days ago),
but that's a different issue.

See my comments from 2001-06-27 13:06 for my opinion, which applies even if the
process does go away by substituting "kill a process" with "wait for a process."

Comment 17

17 years ago
*** Bug 90107 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
This appears to have been handled elsewhere...

*** This bug has been marked as a duplicate of 84896 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 19

17 years ago
SPAM: reassigning OJI bugs to new QA, pmac. (227 bugs)
QA Contact: shrir → pmac

Comment 20

17 years ago
Verified dup
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.