Closed Bug 846524 Opened 7 years ago Closed 7 years ago

Seamonkey build changes for a moz.build compatibility

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.19

People

(Reporter: gps, Unassigned)

References

Details

Attachments

(3 files)

comm-central is mostly building the 'mail' app. However, 'suite' needs a bit more love. Establishing a bug to get it working.
No longer blocks: 845089
Depends on: 845089
Gregory: Can you provide a few hints on how to fix this? Or will you provide a patch?
(In reply to Frank Wein [:mcsmurf] from comment #1)
> Gregory: Can you provide a few hints on how to fix this? Or will you provide
> a patch?

I took a break from working on this to type this comment. Join in #build for progress updates.
Patch supplied by Ms2ger. I think I got the author headers correct! I'll review this.

Do we need to CC any Chatzilla people or can I just push?
Attachment #720086 - Flags: review?(gps)
Same treatment for the dom inspector extension. Anyone need notified or can I just push?
Attachment #720088 - Flags: review?(gps)
More of the same for venkman. Anybody need notified?
Attachment #720090 - Flags: review?(gps)
Attachment #720086 - Flags: review?(gps) → review+
Attachment #720088 - Flags: review?(gps) → review+
Comment on attachment 720090 [details] [diff] [review]
Part 3: Convert venkman, v1

Review of attachment 720090 [details] [diff] [review]:
-----------------------------------------------------------------

Don't we need STANDALONE_MAKEFILE in locales?
Attachment #720090 - Flags: review?(gps)
Comment on attachment 720088 [details] [diff] [review]
Part 2: Convert dom inspector, v1

Review of attachment 720088 [details] [diff] [review]:
-----------------------------------------------------------------

Might also be missing STANDALONE_MAKEFILE for this one too.
I made minor fixes to the patches and pushed to their respective repositories. I self-reviewed a trivial patch to comm-central to fix the path to the extensions directory.

https://hg.mozilla.org/comm-central/rev/952218fceefe

I was able to build Seamonkey locally. So, I'm resolving this bug. Please reopen if it doesn't work on the builders.

I'm not sure if the Target Milestone is correct. I'm sure someone will correct if it isn't!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.19
Duplicate of this bug: 846609
You need to log in before you can comment on or make changes to this bug.