IonMonkey: Remove jsop_call_inline()

RESOLVED FIXED in mozilla22

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sstangl, Unassigned)

Tracking

unspecified
mozilla22
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 719713 [details] [diff] [review]
patch

jsop_call_inline() largely duplicates the behavior of inlineScriptedCall(), for the purpose of being more amenable to inclusion in inlineScriptedCalls(). By making small changes around the callsite of inlineScriptedCalls(), we can standardize on invariants and reuse the existing code.

Normalizing invariants eliminates a lot of messiness for Bug 837312.

Passes jit-tests and runs Octane.
Attachment #719713 - Flags: review?(kvijayan)
Comment on attachment 719713 [details] [diff] [review]
patch

Review of attachment 719713 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #719713 - Flags: review?(kvijayan) → review+
(Reporter)

Comment 2

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/b4d1bc6b9d1a
(Reporter)

Comment 3

5 years ago
Backed out for exciting warnings-as-errors that only reproduce on clang builds:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f61a73af62dd
(Reporter)

Comment 4

5 years ago
"return NULL" => "return false":
https://hg.mozilla.org/integration/mozilla-inbound/rev/36e5e8f66118
https://hg.mozilla.org/mozilla-central/rev/36e5e8f66118
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
Duplicate of this bug: 835180
You need to log in before you can comment on or make changes to this bug.