The user can be moved to the private tabs when closing normal tabs

RESOLVED DUPLICATE of bug 835022

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 835022
5 years ago
a year ago

People

(Reporter: AdrianT, Assigned: bnicholson)

Tracking

({reproducible})

20 Branch
ARM
Android
reproducible
Points:
---

Firefox Tracking Flags

(firefox20+ fixed, firefox21+ fixed, firefox22 verified, fennec20+)

Details

(Reporter)

Description

5 years ago
Firefox Mobile 20 beta 2/Nightly 22.0a1 2013-02-28
Acer A500 (Android 3.2.1)

Steps to reproduce:
1) Open 2 normal tabs
2) Open one or more private tab
3) Open the Tab Drawer and from the Private tabs section open the Tab Drawer menu and open a new normal tab (Alternatively open the normal tab from the Custom menu in landscape)
4) Close the normal tab

Expected result:
The user is taken to the next normal tab

Actual result:
The last opened private tab is displayed and the tab in the Tabs drawer is changed to the Private tabs tab

Notes: 
Please see the video capture: http://youtu.be/Q8APggWKrys
tracking-firefox20: --- → ?

Comment 1

5 years ago
I was able to repro.

Madhava - is this unexpected behavior, or does it break any of our commitments around PB?
Flags: needinfo?(madhava)
I think that closing a tab in a particular one of our tab buckets (normal, private) should NOT take you to another bucket. That kind of context switch will be surprising to users, even aside from whether it creates embarrassing situations for people.

Can this be resolved without totally messing up our "go to next most recently-used tab" logic? I think that still makes sense, but it just should operate within the current bucket.
Flags: needinfo?(madhava)
I'm able to reproduce this too on mozilla-trunk (03.06) and mozilla-aurora (03.06).
Keywords: reproducible
This doesn't appear to cause privacy leaks so assigning to Sriram to look into a possible low risk speculative fix before Tues Mar 12th beta 4 go-to-build.  Otherwise we'll leave this for FF21.
Assignee: nobody → sriram
tracking-firefox20: ? → +
tracking-firefox21: --- → +
Still reproducible on all channels (03/11)
(Assignee)

Comment 6

5 years ago
Is this a dupe of bug 846731? Specifically, see https://bugzilla.mozilla.org/show_bug.cgi?id=835022#c3.
This is closing one of a few regular tab and being context-switched back to the open private tab instead of switching to the next available regular tab.
tracking-fennec: ? → 20+
Assignee: sriram → bnicholson
(Assignee)

Comment 8

5 years ago
IIUC, the first expected behavior listed in https://bugzilla.mozilla.org/show_bug.cgi?id=835022#c3 addresses this one.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 835022
status-firefox20: affected → fixed
status-firefox21: affected → fixed
status-firefox22: affected → fixed
Verified fixed on:
Build: Firefox for Android 22 Beta 1 (2013-05-15)
Device: Acer A500
OS:Android 3.2.1
status-firefox22: fixed → verified
You need to log in before you can comment on or make changes to this bug.