Send without recipients warns about empty subject

RESOLVED DUPLICATE of bug 68784

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 68784
5 years ago
5 years ago

People

(Reporter: Marcos Trentacoste, Unassigned)

Tracking

17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.57 Safari/537.17

Steps to reproduce:

By clicking send without recipients


Actual results:

when I compose a message and click the send button without completing the field and the Subject field. Thunderbird asks me: "if I'm ready to send the message without a subject"


Expected results:

me tendría que advertir en primer lugar: que no hay destinatario para enviar el mensaje

Updated

5 years ago
Component: Untriaged → Message Compose Window
(Reporter)

Comment 1

5 years ago
Expected results English:

I should note first: there is no recipient to send the messag

Comment 2

5 years ago
Thanks, that's what I figured from the Spanish above.

So, the problem (and I can reproduce on 17.0.3) is that an empty subject without providing any recipients will first produce the "empty subject" warning, allowing you to "send" it with an empty subject, which results in the "no recipients" error and the message won't be sent in the end.

Thus, the "no recipients" error should outweigh any warnings (especially such which claim to actually send the message), thus only that error dialog shown and all other prior checks and warnings omitted.
Summary: By clicking send without recipients → Send without recipients warns about empty subject

Comment 3

5 years ago
If my comment #2 correctly says what you want to achieve, then your bug is a duplicate of long-standing bug 68784 (which actually has a patch already up and received positive feedback, so this issue may be resolved fairly soon).
Whiteboard: dupeme?

Comment 4

5 years ago
Yes, looks like dupe of 68784. And I should get back to fixing that one :)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme?
Duplicate of bug: 68784
You need to log in before you can comment on or make changes to this bug.