Closed Bug 847382 Opened 8 years ago Closed 8 years ago

xulrunner builds are broken

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(firefox21 fixed)

RESOLVED FIXED
mozilla22
Tracking Status
firefox21 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(2 files, 3 obsolete files)

https://tbpl.mozilla.org/php/getParsedLog.php?id=20291605&tree=Firefox

make -j4 -C obj-firefox sdk
make[1]: Entering directory `/builds/slave/m-cen-lx-xr-ntly-0000000000000/build/obj-firefox'
make: Entering an unknown directory
make: *** xulrunner/installer: No such file or directory.  Stop.
make: Leaving an unknown directory
make[1]: *** [sdk] Error 2
Attachment #720664 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/b55a438b74e2
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
[ajvincent@localhost xu-opt]$ make sdk
make[1]: Entering directory `/home/ajvincent/trunk/xu-opt/xulrunner/installer'
/home/ajvincent/trunk/mozilla/config/rules.mk:35: backend.mk: No such file or directory
Makefile:72: FULL_NSPR_CFLAGS=-I\${includedir}
make[1]: *** No rule to make target `backend.mk'.  Stop.
make[1]: Leaving directory `/home/ajvincent/trunk/xu-opt/xulrunner/installer'
make: *** [sdk] Error 2
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This isn't quite enough - the patch for bug 812105 doesn't work.  Probably a relative path problem...

/home/ajvincent/trunk/xu-opt/config/nsinstall -D ../../dist/sdk/
USE_ELF_HACK= /home/ajvincent/trunk/xu-opt/_virtualenv/bin/python toolkit/mozapps/installer/strip.py ../../dist/xulrunner-sdk
/home/ajvincent/trunk/xu-opt/_virtualenv/bin/python: can't open file 'toolkit/mozapps/installer/strip.py': [Errno 2] No such file or directory
Attachment #721070 - Flags: review?(mh+mozilla)
Attached patch patch 2 (obsolete) — Splinter Review
This does fix the SDK building.
Attachment #721070 - Attachment is obsolete: true
Attachment #721070 - Flags: review?(mh+mozilla)
Attached patch patch 2 (obsolete) — Splinter Review
sorry about the bugspam; I forgot to export qtip.
Attachment #721074 - Attachment is obsolete: true
Attachment #721076 - Flags: review?(mh+mozilla)
Comment on attachment 721076 [details] [diff] [review]
patch 2

Review of attachment 721076 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/mozapps/installer/packager.mk
@@ +693,5 @@
>  	(cd $(DIST)/sdk/lib && $(TAR) $(TAR_CREATE_FLAGS) - .) | \
>  	  (cd $(DIST)/$(MOZ_APP_NAME)-sdk/lib && tar -xf -)
>  	$(NSINSTALL) -D $(DIST)/$(SDK_PATH)
>  ifndef PKG_SKIP_STRIP
> +	USE_ELF_HACK= $(PYTHON) $(topsrcdir)/toolkit/mozapps/installer/strip.py $(DIST)/$(MOZ_APP_NAME)-sdk

Use MOZILLA_DIR instead of topsrcdir
Attachment #721076 - Flags: review?(mh+mozilla) → review+
Attachment #721076 - Attachment is obsolete: true
Attachment #721083 - Flags: checkin?(mh+mozilla)
https://hg.mozilla.org/mozilla-central/rev/015da7030aab
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Attachment #721083 - Flags: checkin?(mh+mozilla) → checkin+
Backed out for not following the tree rules (watching/starring mozilla-central after pushing):
https://hg.mozilla.org/mozilla-central/rev/47876c1d1c45
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #720664 - Flags: checkin+
Attachment #721083 - Flags: checkin+ → checkin-
https://hg.mozilla.org/mozilla-central/rev/2c217df0f901
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Blocks: 845350
No longer blocks: 845350
Comment on attachment 721083 [details] [diff] [review]
patch 2, adjusted for r+

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Linux XULRunner SDKs are 10x the size they need to be, causing longer downloads for users of them.
Testing completed (on m-c, etc.): Applied patch locally.

Paired with bug 812105.
Attachment #721083 - Flags: approval-mozilla-beta?
Comment on attachment 721083 [details] [diff] [review]
patch 2, adjusted for r+

10:37 < bhearsum|buildduty> lsblakk: i  just asked for approval for https://bugzilla.mozilla.org/show_bug.cgi?id=812105 and https://bugzilla.mozilla.org/show_bug.cgi?id=847382, but then glandium pointed out to me that a=NPOTB 
                            has been used for xulrunner things before. can i go ahead and land them on beta?
10:43 < lsblakk> ya

https://hg.mozilla.org/releases/mozilla-beta/rev/5f41d8b47686
Attachment #721083 - Flags: approval-mozilla-beta?
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.