Last Comment Bug 847463 - Top contributor dashboard busted
: Top contributor dashboard busted
Status: RESOLVED FIXED
u=contributor c=questions p=1 s=2013.5
:
Product: support.mozilla.org
Classification: Other
Component: Questions (show other bugs)
: unspecified
: All All
: P1 normal (vote)
: 2013Q1
Assigned To: Ricky Rosario [:rrosario, :r1cky]
: kb-software
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-04 09:20 PST by Kadir Topal [:atopal]
Modified: 2013-03-07 02:10 PST (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Kadir Topal [:atopal] 2013-03-04 09:20:51 PST
The contributor dashboard is supposed to list 10 names and base the ranking on the karma data of the last 3 month. Currently it's unclear what the ranking is based on and it's only listing 9 names instead of 10.
Comment 1 Alice Wyman 2013-03-04 12:05:12 PST
I brought this up in https://etherpad.mozilla.org/sumo-2013-02-25 
... under Metrics:

Review suspicious "helpful" votes on support forum, which is affecting Top10 and Top25 contributor rankings.  Note Feb 18 post by madperson https://support.mozilla.org/en-US/forums/contributors/708886?last=50880&page=3#post-50878 "helpfulness votes spiked to 75% yesterday in the kpi chart"
Comment 2 Ricky Rosario [:rrosario, :r1cky] 2013-03-05 07:43:15 PST
I don't know what the issue is here. Making this a 1pter assuming it's a lame bug. If it is a bigger issue, we should adjust that.
Comment 3 Ricky Rosario [:rrosario, :r1cky] 2013-03-06 07:04:02 PST
I verified that the users shown are indeed the correct top 9. So, far I can't figure out why it isn't showing 10. I wonder if there is a user that got deleted or deactivated later.
Comment 4 Alice Wyman 2013-03-06 09:23:10 PST
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #3)
> I verified that the users shown are indeed the correct top 9. 

Even Top 10 contributor MandoAtef *  ...who got over 300 helpful votes for each of his answers in a single thread?  (In fact, everyone who posted in that thread, up until Feb 17th, got over 300 votes for each answer.)  

https://support.mozilla.org/en-US/questions/950321

[*] https://support.mozilla.org/en-US/user/848037
Comment 5 Ricky Rosario [:rrosario, :r1cky] 2013-03-06 10:02:17 PST
(In reply to Alice Wyman from comment #4)
> (In reply to Ricky Rosario [:rrosario, :r1cky] from comment #3)
> Even Top 10 contributor MandoAtef *  ...who got over 300 helpful votes for
> each of his answers in a single thread?=

Well that is a different issue that we are trying to fix with rate limiting (bug 785850) and, potentially, an issue in how we determine top contributors.
Comment 6 Alice Wyman 2013-03-06 11:17:12 PST
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #5)
> (In reply to Alice Wyman from comment #4)
> > (In reply to Ricky Rosario [:rrosario, :r1cky] from comment #3)
> > Even Top 10 contributor MandoAtef *  ...who got over 300 helpful votes for
> > each of his answers in a single thread?=
> 
> Well that is a different issue that we are trying to fix with rate limiting
> (bug 785850) and, potentially, an issue in how we determine top contributors.

In that case, I'll leave it to Kadir, Madalina, or someone else to file a new bug about how we determine top contributors ... or ask that the votes in https://support.mozilla.org/en-US/questions/950321 be deleted.
Comment 7 Noah (oldtimer) [:Noah] 2013-03-07 01:16:08 PST
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #3)
> I verified that the users shown are indeed the correct top 9. So, far I
> can't figure out why it isn't showing 10. I wonder if there is a user that
> got deleted or deactivated later.

There was a user who was deactivated (StelianPilici https://support.mozilla.org/en-US/user/833572 ). It looks like his account may have been deleted. Although I thought we didn't do that for db corruption/other funniness reasons. Jsocol has also strongly warned against deleting users in the past citing db problems.

Ricky, is it possible to do a git bisect on the time range of 2/3/2013 to 2/11/2013? It looks like somewhere in that time someone may have altered the Top 10 Contributors code and caused this missing spot as a result. Or maybe the Top 10 code has to be rewritten to account for situations where users suddenly cease to exist?

2/11/13 looks to be the date this busted.

Info for time range from:
https://support.mozilla.org/en-US/forums/contributors/708886?page=3#post-50740

2/11/13 10:19pm CST
Not completely. I have been hovering at #11 spot for a long while now because of user833572 (SilianPilici) taking up #6 spot and I am still at #11, yet I see dumdidadida who has not posted since November is at #10. 


2/11/13 11:35pm CST
Now, there is only 9 showing instead of the regular 10. Something is fishy now. And I also agree with James, dumdidadida is oddly up there - maybe he is getting helpfuls on old thread questions? Could somebody look into it?
Comment 8 Ricky Rosario [:rrosario, :r1cky] 2013-03-07 01:41:25 PST
(In reply to Noah (oldtimer) [:Noah] from comment #7)
> There was a user who was deactivated (StelianPilici
> https://support.mozilla.org/en-US/user/833572 ). It looks like his account
> may have been deleted.

I think this is the issue. If so this will fix it:
https://github.com/mozilla/kitsune/commit/c9f471dd5f960d040e3fb73492a214daf5c620d8
Comment 9 Ricky Rosario [:rrosario, :r1cky] 2013-03-07 02:10:41 PST
This is fixed in prod now.

Note You need to log in before you can comment on or make changes to this bug.