[FIX]making history.dat readonly renders url bar inoperative

RESOLVED FIXED in mozilla1.0

Status

SeaMonkey
Location Bar
P5
trivial
RESOLVED FIXED
17 years ago
10 years ago

People

(Reporter: gsa, Assigned: bz)

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [readonly])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060712

I did a "get info" on the history.dat file and locked it so Mozilla can't write
to it. rebooted Mozilla. Now Url Bar doesn't work anymore.

Reproducible: Always
Steps to Reproduce:
1. select "history.dat" file in Mozilla profiles folder
2. using "get info" command lock it so it cannot be written to
3. reboot Mozilla, enter a url in the url bar and try to activate it

Actual Results:  Nothing happens

Expected Results:  url entered in the url bar should have activated

Comment 1

17 years ago
nobody said that was supported :)
moving to future..
Priority: -- → P3
Target Milestone: --- → Future
(Reporter)

Comment 2

17 years ago
After checking the Javascript Console I found this error which resulted from
locking the history.dat file

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIAutoCompleteSession.onStartLookup]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://global/content/autocomplete.xml#autocomplete.startLookup() ::
startLookup :: line 12"  data: no]

Comment 3

17 years ago
This should probably be invalid because nothing says that you should do this.
It's kindof like filing a bug saying that when I delete dlls, shlbs, and .so
files, then the browser doesn't run... However, because it looks like Alecf has
some intention of fixing this at a later point in time, I'll confirm it. Alecf,
if I got you wrong here, let me know or close this out...

Thanks

Zach
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
this is one of those things that embedders would probably like, or people who 
want to run moz off a cdrom.

So is mork choking or what?
OS: Mac System 9.x → All
Hardware: Macintosh → All
Summary: making history.dat unwritable renders url bar inoperative → making history.dat readonly renders url bar inoperative
Whiteboard: [readonly]

Comment 5

17 years ago
reassign url bar bugs to new owner..
Assignee: alecf → blakeross
Target Milestone: Future → ---

Updated

17 years ago
Severity: major → minor
Target Milestone: --- → Future

Comment 6

17 years ago
reassigning url bar bugs to default owner.
Assignee: blakeross → hewitt
Target Milestone: Future → M1

Updated

17 years ago
Target Milestone: M1 → ---

Updated

17 years ago
Severity: minor → trivial
Status: NEW → ASSIGNED
Priority: P3 → P5
Target Milestone: --- → Future
Created attachment 68340 [details] [diff] [review]
Patch v1.0

Patch to fix.  Don't leave our listeners hanging because of our internal
problems!
taking bug.
Assignee: hewitt → bzbarsky
Status: ASSIGNED → NEW
Summary: making history.dat readonly renders url bar inoperative → [FIX]making history.dat readonly renders url bar inoperative
Target Milestone: Future → mozilla1.0
Created attachment 68344 [details] [diff] [review]
Patch v 1.1

Better patch
Attachment #68340 - Attachment is obsolete: true

Updated

16 years ago
Attachment #68344 - Flags: review+

Comment 10

16 years ago
Comment on attachment 68344 [details] [diff] [review]
Patch v 1.1

don't increment mFailureCount yourself, call this.searchFailed() which does
that and then some.
Attachment #68344 - Flags: needs-work+
Created attachment 68445 [details] [diff] [review]
Patch v 1.2

call this.searchFailed() (have to decrement this.mSessionReturns manually for
things to work, though).
Attachment #68344 - Attachment is obsolete: true

Comment 12

16 years ago
Comment on attachment 68445 [details] [diff] [review]
Patch v 1.2

sr=hewitt
Attachment #68445 - Flags: superreview+

Updated

16 years ago
Attachment #68445 - Flags: review+
checked in
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.