A garbage menuitem exists in the View -> Sidebar menupopup

RESOLVED DUPLICATE of bug 846075

Status

()

Firefox
SocialAPI
RESOLVED DUPLICATE of bug 846075
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

22 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox22-)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 721111 [details]
screenshot

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/86c98c4d36da
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130304 Firefox/22.0 ID:20130304030933

Reproduced: Always

Steps To Reproduce:
1. Start Firefox with newly created clean profile
2. Open Sidebar menu (keypress Alt V E)

Actual Results:
A garbage menuitem exists in the menupopup.

Expected Results:
The garbage menuitem should be completely hidden.


Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/c233837cce08
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130224 Firefox/22.0 ID:20130225010544
Bad:
http://hg.mozilla.org/mozilla-central/rev/06935f2db267
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130225 Firefox/22.0 ID:20130225111636
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c233837cce08&tochange=06935f2db267


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e83b8bbf1d5e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130224 Firefox/22.0 ID:20130224141136
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3892ce628367
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130224 Firefox/22.0 ID:20130224164835
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e83b8bbf1d5e&tochange=3892ce628367

rgressed by:
3892ce628367	Mark Hammond — Bug 833292 - prevent social initialization completing after window is unloaded. r=jaws
Reproducible, thanks Alice. Note that I can make this blank menu item disappear by clicking it. Tested on Linux so this is not a Windows-only bug.
OS: Windows 7 → All
Hardware: x86_64 → All

Comment 2

5 years ago
Created attachment 721897 [details]
fx22.0a1 2013-03-06 sidebar menu blank item
This is just another manifestation of incorrect UI initialization when social isn't enabled at startup.  I've verified the patch in bug 846075 also fixes this and I'll land it as soon as the trees reopen.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 846075

Updated

5 years ago
tracking-firefox22: ? → -
You need to log in before you can comment on or make changes to this bug.