PDF text Missing when viewed with ff pdf viewer [unimplemented annotation type:FreeText]

RESOLVED WORKSFORME

Status

()

Firefox
PDF Viewer
P3
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: James, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-feature], URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130227063501

Steps to reproduce:

When viewing certain PDF's using the default PDF viewer in Firefox 19 and 20 a blue bar appears above the PDF saying This PDF document might not be displayed correctly giving the user an option to open with a different viewer. The problem is that only 1/2 the PDF displays and unless the user decides to click on Open with Different Viewer to compare the results they are left with missing information.  

It appears to be an issue with PDF's that have text typed on them using Acrobats typewriter tool. Everything typed on the PDF using the typewriter tool is completely missing but the rest of the PDF gets displayed. I tried printing the PDF using the print Icon below the blue bar and still don't see the typewriter text. If I save the PDF and open it with Adobe Reader the text is now visible.


Actual results:

Here is a link to a PDF file that doesn't display properly in Firefox but does in Adobe Reader. 

http://www.concomaps.com/Commercial/618.pdf


Expected results:

If the PDF can't be displayed properly cant there be a popup or something that warns the user that the PDF they are trying to view should be opened with an external app for compatibility reasons or go ahead and let Firefox attempt to display it?

Updated

5 years ago
Component: Untriaged → PDF Viewer
Reproducible on the latest Nightly.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130309 Firefox/22.0
Build: 20130309030841
OS: Windows 7 x64
Status: UNCONFIRMED → NEW
Ever confirmed: true
The console gives the following information:
[17:55:30.781] PDF 43dd5812ef71eeb69bd43f2357e5 [1.5 Acrobat Distiller 10.1.3 (Windows) / PScript5.dll Version 5.2.2] (PDF.js: 0.7.236)
[17:55:31.239] Warning: TODO: unimplemented annotation type: FreeText
Summary: PDF text Missing when viewed with ff pdf viewer → PDF text Missing when viewed with ff pdf viewer [unimplemented annotation type:FreeText]

Updated

5 years ago
Priority: -- → P3
Whiteboard: [pdfjs-c-feature]

Updated

5 years ago
Duplicate of this bug: 849479

Comment 4

5 years ago
This might well be dupe of Bug 7412399, too.

Comment 5

5 years ago
(In reply to john ruskin from comment #4)
> This might well be dupe of Bug 7412399, too.

I'm sorry:  dupe of 741239

See also: Bug 846650, Bug 848476, Bug 849527 and Bug 849357
For overlapping bugs issues, and for variable importance ratings...

Comment 6

5 years ago
In the latest Nightly, I don't have issue viewing the annotation.
James, is it OK close it?

There's still an error but with no visible effect:
"Warning: AcroForm/XFA is not supported"
Flags: needinfo?(jamesb)
(Reporter)

Comment 7

5 years ago
The problem is fixed using Firefox 23!  

Thanks for getting this issue fixed everyone.
Flags: needinfo?(jamesb)
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.