Native PDF viewer does not display annotations

RESOLVED DUPLICATE of bug 741239

Status

()

Firefox
PDF Viewer
P3
major
RESOLVED DUPLICATE of bug 741239
5 years ago
5 years ago

People

(Reporter: john ruskin, Unassigned)

Tracking

19 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-feature])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

Viewed PDF with annotations added with Nitro Reader/.

PDF created originally by PDFCreator


Actual results:

Annotation layer is absent when viewed with Native Fox19 PDF viewer


Expected results:

Displayed the annotations.

ALSO:
1.   Content warning displayed is inadequate, as it should read "content is missing", rather than "displayed incorrectly".
2.   Underlying basis of content warning by Native PDF viewer should be accessible to the reader/user, when the error is put up by Fox19
3.   The warning bar should not disappear if the Fox19 viewer identifies an error unless the warning, itself, is explicitly dismissed.   Currently, the warning disappears if the user makes a choice regarding use of an alternate viewer.
4.   The warning should be present in a print dialog, offered by Fox19, for a document which has the error bar (ie, has deficiencies known to Fox19)
4a....and IMO printed on the document when printed.   Otherwise the inference is that the printed document -is- what is displayed and -is- what the author created.
5.   The install of Fox19 (or subsequent version) and of the native viewer should not automatically override the prior choice for a PDF viewer, without user intervention/warning.
6.   On install, the application table creates multiple entries for PDF files -- one set from (for example) the Adobe Reader, and then another line-entry for the "Portable Document Format" that reflects behavior of the native viewer.
7.  After install, the native viewer application disrupts the Fox-on-tab behavior of Adobe and other viewers, instead forcing the file open to an Adobe stand alone file.   The install also disrupts the underlying instruction not to open a blank tab, when the file is handled by Fox19 using Adobe or another viewer, after maneuvering the application table back towards pre-install conditions.
(Reporter)

Updated

5 years ago
Severity: normal → major
Component: Untriaged → PDF Viewer
(Reporter)

Comment 1

5 years ago
Created attachment 723087 [details]
Test case for bug report

PDF created using PDFCreator, and subsequently annotated with NitroReader3.   The native viewer does not display the annotation.   Adobe Reader 9.5.4 does.
This is reproducible on the latest Nightly.  The annotation layer is missing.  The other points raised are valid but I am not sure if this is by design.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130309 Firefox/22.0
BuildID: 20130309030841
OS: Windows 7 x64
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

5 years ago
Just an additional thought -- these issues should probably be addressed immediately in Fox19 and equivalent sea monkey, rather than waiting for corrections in versions >=20.

... Particularly when PDFs become mission critical elements in legal documents, construction and engineering design.   The PDF's author expects the PDF's user/reader will see all content, and in this case, neither the author or user would know that a user did not see all contents.   I can envision this:
Author creates and then publishes to the web a PDF with annotation
User views a multipage PDF on Fox19, 
User approves of its contents, 
User Saves a copy locally,
and then the User emails a returned ok to the Author/Sender.

I could even see where that user:
signs off on the final page using a digital signature, and sends back the very -same- digital document (with his own annotation/signature), without even knowing that his view of the copy in Fox19 was defective (and would never know unless he reopened the document outside of Fox19, and re-read the -whole- thing).

A subtle other problem:
An author, knowing about this defect, could take advantage of anyone using a Fox19 viewer.   I consider this to be a security defect, but that idea was nixed in another bug report.

And, finally, I apologize -- I actually don't know, per 4a, above: this:  4b: (Does) the printed copy of a faulty displayed PDF print the missing annotation layer (?)

John Ruskin
BS/MS Engineering, JD
This is likely a dup of bug 848476 (Annotation not implemented: FreeText).

Updated

5 years ago
Whiteboard: [pdfjs-c-feature]

Updated

5 years ago
Priority: -- → P3
Duplicate of bug 741239.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741239
You need to log in before you can comment on or make changes to this bug.