Last Comment Bug 848635 - Old queries based on tags are no longer listed in the page footer by default when upgrading from 4.0 or older to 4.2
: Old queries based on tags are no longer listed in the page footer by default ...
Status: RESOLVED FIXED
: regression
Product: Bugzilla
Classification: Server Software
Component: Installation & Upgrading (show other bugs)
: 4.2.5
: All All
: -- normal (vote)
: Bugzilla 4.2
Assigned To: Frédéric Buclin
: default-qa
Mentors:
: 850532 (view as bug list)
Depends on: 616185
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-06 18:19 PST by Frédéric Buclin
Modified: 2013-04-28 04:52 PDT (History)
2 users (show)
LpSolit: approval+
LpSolit: approval4.4+
LpSolit: approval4.2+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch, v1 (1.30 KB, patch)
2013-04-13 05:02 PDT, Frédéric Buclin
glob: review+
Details | Diff | Review

Description Frédéric Buclin 2013-03-06 18:19:37 PST
I just realized that after the bmo upgrade, all my queries based on the old tagging system are no longer displayed in the page footer. This change has been silently made by mkanat without asking anyone for review, see bug 616185 comment 42. He mentions a discussion with me on IRC, but we never discussed removing these queries from the page footer. Here is the transcript from January 31, 2011:

(22:35:15) mkanat: LpSolit: Hey hey. Would you mind if I slightly fix up that Install::DB code for tags--the bit that you fixed?
(22:35:28) mkanat: LpSolit: I could either post a new patch and you could review it, or I could just do it as DB module owner, whatever you'd prefer.
(22:36:17) LpSolit: mkanat: what do you want to change?
(22:36:38) mkanat: LpSolit: Oh, wanted to put it in a transaction, remove the eval, use URI.pm.
(22:37:32) LpSolit: mkanat: adding the transaction is fine, but removing the eval {} won't work in case an installation is already partially updated
(22:37:44) mkanat: LpSolit: Those would have only existed for the past day or so, though.
(22:37:47) mkanat: LpSolit: Or even only for a few hours.
(22:37:54) LpSolit: mkanat: for a few hours only
(22:38:04) LpSolit: for 6 hours, I think
(22:38:19) mkanat: LpSolit: Okay. So I figure that they've probably all updated by now (at least, all our automated updaters have), so we can remove it so that we're not hiding any real errors that people experience when they update to 4.2 from 4.0 or earlier.
(22:38:48) LpSolit: mkanat: ok
(22:39:04) mkanat: LpSolit: Okay. I can post the patch for you, if you want.
(22:40:17) LpSolit: mkanat: just attach it to the bug, for the record
(22:40:21) mkanat: LpSolit: Okay.


There is no way to fix this problem for already upgraded installation as there is no way to know which saved searches were displayed in the page footer before the upgrade and which ones weren't. So all we can do is to fix this problem for installations which didn't upgrade to 4.2 or newer yet.

I first thought these saved searches were lost and I started recreating one of them, and suddenly saw that the message said "saved search updated" instead of "saved search created", which is how I realized that they were still somewhere in the DB. I had to go through my 40+ saved searches to re-enable the ones I previously had in my page footer. That's painful (and confusing for those who are not too familiar with Bugzilla).
Comment 1 Reed Loden [:reed] (use needinfo?) 2013-03-12 21:27:57 PDT
*** Bug 850532 has been marked as a duplicate of this bug. ***
Comment 2 Frédéric Buclin 2013-04-13 05:02:18 PDT
Created attachment 737122 [details] [diff] [review]
patch, v1
Comment 3 Byron Jones ‹:glob› 2013-04-24 00:04:11 PDT
Comment on attachment 737122 [details] [diff] [review]
patch, v1

r=glob
Comment 4 Frédéric Buclin 2013-04-28 04:52:48 PDT
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Install/DB.pm
Committed revision 8617.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.4/
modified Bugzilla/Install/DB.pm
Committed revision 8550.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.2/
modified Bugzilla/Install/DB.pm
Committed revision 8210.

Note You need to log in before you can comment on or make changes to this bug.