mozilla displays "unread: -1 total: -1" for my trash folder

VERIFIED WORKSFORME

Status

MailNews Core
Database
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: tobias, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060703



Reproducible: Always
Steps to Reproduce:
1.open mozilla mail
2.go to trash
3.read status bar
(you probably cannot reproduce it because it's probably because the database of
my mails has i guess several faults)

Actual Results:  "unread: -1 total: -1"
was displayed

Expected Results:  display "unread: 0 total: 0"

I don't know the reasons for the many problems I have with Mozilla Mail, but I
guess they come from problems with the "database". I copied my database from
version to version. I bet several files of the database got corrupted in the
course of time. And now the mailer app has problems to deal with those files.
The app should be more immune to unexpected databases and should be able to fix
those problems.
(Assignee)

Comment 1

17 years ago
No, I can't reproduce this so it's not very useful. You can delete your .msf
file for your trash, or simply emptying your trash should also fix this count
because emptying the trash removes the db and creates a new empty one.
(Reporter)

Comment 2

17 years ago
ok it works just fine again. now theres an file in the trash which 
shouldnt be there. you really should integrate some checks if the db 
values are valid. this would probably solve many problems with the mail 
app (i assume).

Comment 3

17 years ago
I have a fix for the unread count problem. See bug 59871. Marking this
worksforme based on last comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
VERIFIED wfm (6/8 build, win2k)
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.