"Trash" still shows messages in bold even after emptying trash on IMAP server

VERIFIED FIXED in mozilla0.9.3

Status

P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: jnichols, Assigned: naving)

Tracking

({polish})

Trunk
mozilla0.9.3
polish

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+][nsbranch+,pdt+]Have Fix)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
As far as I can tell, this is only happening on an AppleshareIP 6.3.2 mail
server. (logged in with IMAP)
1)Get a new message or 2..
2)delete an unread message
3)choose "Empty Trash"

Trash will remain in bold with the message count displayed. If I go into the
trash, it goes back to the normal non-bold grey text.

Happens every time I check my mail on my Appleshare IP box. Including version
20001110...

I tried playing with some of the IMAP settings, but they don't seem to make a
difference..

Comment 1

18 years ago
This problem has been around a long time, I bet there's a duplicate out there
... will look for it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: esther → laurel

Comment 2

18 years ago
what if you expand and collapse the top-level imap server, without opening the
trash? Does the folder count get updated correctly? I.e., is this just an
update/redraw problem?
(Reporter)

Comment 3

18 years ago
Tried collapsing it.. it's most noticible when there's a deleted new message.
collapsing it didn't work, but if I click "Trash" it'll go in the folder,
realize it's supposed to be empty, and update accordingly..

Comment 4

18 years ago
*** Bug 62584 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
Found this bug in Win 98 also on 2000120920.

Comment 6

18 years ago
*** Bug 64856 has been marked as a duplicate of this bug. ***

Updated

18 years ago
OS: Mac System 9.x → All
Hardware: Macintosh → All

Comment 7

18 years ago
*** Bug 72996 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
*** Bug 73663 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
I see this with today's win32 (2001041009) build against nsmail-1 in imap.  I
delete a message that's unread, the trash folder goes bold, I empty trash and it
doesn't go unbold until I click on the folder.  If I collapse the sidebar/folder
pane and reopen it, it stays bold.
The same happens with POP too (win98, 2001-05-13-10-trunk, also in duped bug
64856). Even restarting mail doesn't update the count. The summary is confused:
"shows messages in bold"? The description nor the comments describe messages
shown in bold, but the folder name and message count.
Keywords: nsbeta1, nsCatFood, polish

Comment 11

18 years ago
moving to mozilla0.9.2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9.2

Comment 12

18 years ago
balancing to naving. 
Assignee: mscott → naving

Comment 13

18 years ago
I think we're not clearing the pending counts when we empty the trash.
(Assignee)

Comment 14

18 years ago
Created attachment 35310 [details] [diff] [review]
proposed fix
(Assignee)

Comment 15

18 years ago
The counts were not changing only for imap. For pop3 it worksforme. The fix is 
to update the counts in OnStopRunningUrl. Need review, david.  

Comment 16

18 years ago
r=bienvenu

Updated

18 years ago
Whiteboard: [nsbeta1+] → [nsbeta1+]Have Fix

Comment 17

18 years ago
I have this problem with POP3 (2001053115 on RedHat Linux 7.1), so it is not
just an IMAP problem.
(Assignee)

Comment 18

18 years ago
When you do File | Empty Trash or right click Empty Trash on pop3 we delete the 
trash folder and create a new trash folder, so it should not show anything in 
bold. 

Comment 19

18 years ago
May be it shouldn't, but it does. It goes away when I click on it, though. Is it
possible that it's just a question of the folder pane not being refreshed properly?
(Assignee)

Comment 20

18 years ago
Created attachment 36942 [details] [diff] [review]
fix for the pop3 part
(Assignee)

Comment 21

18 years ago
The fix is basically call UpdateFolder on the newly created Trash folder 
so that counts are updated. request for review, david ?

Comment 22

18 years ago
r=bienvenu

Comment 23

18 years ago
moving to 0.9.3.  Please hold onto the fix in case we can get in later.
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Updated

18 years ago
Keywords: nsBranch

Comment 24

18 years ago
sr=mscott for both patches.
(Assignee)

Comment 25

18 years ago
*** Bug 80665 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 26

18 years ago
fix landed on trunk.
*** Bug 88273 has been marked as a duplicate of this bug. ***

Comment 28

18 years ago
adding vtrunk keyword to indicate the bug has been fixed on the trunk.  Bug left
open for tracking checkin to branch (nsbranch) when appropriate.

Once bug has been fixed on the branch also, pls remove vtrunk keyword.
Keywords: vtrunk

Comment 29

18 years ago
If this patch gets in, please remember to take out the CompactAll (which I think
is part of another bug that we decided not to take).  If I'm wrong about that,
ignore me.
(Assignee)

Comment 30

18 years ago
yep, i will take care of that. 

Comment 31

18 years ago
trunkverified
using trunk builds 2001-07-02, this is fixed.  I checked IMAP, POP and WebMail
IMAP accounts for this.  They all worked fine.  

Comment 32

18 years ago
I take back the trunkverified,  I found a problem with this fix.
Select messages in a pop inbox
Delete them
File|Empty trash
Select a message in the inbox and wait a second. 
Result: the thread pane is blank
Does not happen with branch build, still checking this scenario. Same true on
linux and mac

Comment 33

18 years ago
The problem I found is with POP only.

Comment 34

18 years ago
For Mac, running through this scenario, I get one of those "Unknown Errors" 
Error 80004005.  From then on, selecting msgs in the tread pane for the Inbox
gives me the error.  Changing folders doesn't help.  I have to exit app and 
relaunch.
(Assignee)

Comment 35

18 years ago
On the trunk CompactAll after Empty Trash bug 61960 is checked in. 
i will back that one out. I know that is what is causing problems that 
esther mentions. 
Scott, do you want this to be verified again on trunk after I back out 61960
or do you want me to go ahead and check this fix on branch. I am pretty
sure it should work

Comment 36

18 years ago
Let's get this verified on the trunk again.  If you can get it checked in today
then we can test it on Thursday.  If it passes we can get it checked in for
Friday's build.
(Assignee)

Comment 37

18 years ago
Please verify this again on thursday on trunk. I have just removed the 
CompactAll part of emptyTrash for local folders.

Comment 38

18 years ago
Using trunk builds 2001-07-04 the problem I mentioned on 7-3 with unknown errors
for mac and missing thread pane content is gone.  making this  trunkverified again

Updated

18 years ago
Whiteboard: [nsbeta1+]Have Fix → [nsbeta1+][nsbranch+]Have Fix

Comment 39

18 years ago
When the branch is open, please check this into it today.
Whiteboard: [nsbeta1+][nsbranch+]Have Fix → [nsbeta1+][nsbranch+,pdt+]Have Fix
(Assignee)

Comment 40

18 years ago
fix checked in on branch
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 41

18 years ago
Verified OK on jul09 0.9.2 branch builds with win98, linux rh6.2 and mac OS 9.0
OK with IMAP, POP.
since esther already did the verification on the trunk, I'll mark this verified.
Status: RESOLVED → VERIFIED

Comment 42

18 years ago
*** Bug 90302 has been marked as a duplicate of this bug. ***

Comment 43

18 years ago
*** Bug 90350 has been marked as a duplicate of this bug. ***

Comment 44

17 years ago
This bug regressed for POP; in Build ID 2001102215 the total message count for
Trash is never updated - see bug 64856 (I reopened it).
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.