Closed Bug 849703 Opened 7 years ago Closed 2 years ago

[Wi-Fi][Settings] Setting the Static IP Address is needed for Wi-Fi

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:backlog)

RESOLVED WONTFIX
tracking-b2g backlog

People

(Reporter: leo.bugzilla.gecko, Unassigned)

References

Details

(Keywords: feature, foxfood)

Attachments

(2 files)

Setting the static IP Address is needed for wifi hardware test.
Check the attached png files.
These files show the android setting for static address.
The setting is needed like android's.
Assignee: nobody → vchang
Hi,

From my point of view this bug is important. There are a lot of places such as companies where you have need an assigned ip to access it, and you can't use a Firefox OS device because of this.
This should be done in gaia, the gecko back-end is completed in Bug 834573 - B2G Wifi: IP and default route still exist after forget network. Drop the bug and let gaia expert to do it.
Assignee: vchang → nobody
Unable to use wifi on my ZTE Open due to this restriction. Need a fix asap.
This bug is preventing me from using one of my wifi routers with Firefox OS, which happens to be the closest router to my work place. Is there any workaround I can use? Even if it involves sending commands and scripts over adb to the device.

Thank you!

(I would also suggest a priority bump - this is part of basic network settings...)
This should only involve UI work per comment 3. Mark as 1.4? for triaging.
blocking-b2g: --- → 1.4?
As we are going to start the development of v1.4, this should be planned in v1.5.
blocking-b2g: 1.4? → 1.5?
Adding to backlog so this isn't lost.
Blocks: 908549
Depends on: 786700
There is already api for this bug.
Moving into backlog first.  
Ravi, let's address all the missing WiFi settings at once, please add this to your request list if you have others.
blocking-b2g: 1.5? → backlog
Flags: needinfo?(rdandu)
This is the backlog roadmap list for WiFi: WLAN23.
Flags: needinfo?(rdandu)
Blocks: 999842
I recently bought Intex Cloud FX which has Intex_Cloud_FX_V07 OS. This phone too has the same problem. I am unable to manually configure IP address in wifi.
Symphony GoFox 15 released few days ago in Bangladesh. Some use are asking for this feature. It will be better if we can fix this bug.
Duplicate of this bug: 1095947
Hey Guys! I have a potential contributor here, who would like some mentoring and would gladly help out fixing this issue. Ádám Fónagy (reporter of bug #1095947) would love to help out - would anyone step up and help him through fixing this?
Flags: needinfo?(timdream)
Sure! Why not. But first we need a UX spec from Jenny.

Arthur, could you assign a mentor here?
Assignee: nobody → adam.fonagy
Status: NEW → ASSIGNED
Flags: needinfo?(timdream)
Flags: needinfo?(jelee)
Flags: needinfo?(arthur.chen)
Flags: needinfo?(adam.fonagy)
EJ will help mentor this bug. Thanks, EJ.
Mentor: ejchen
Flags: needinfo?(arthur.chen)
Hi, as Flaki told I'm in to fix this bug. This is my first time contributing with FFOS so be patient.
Please let me know what is next step.
Hi Bruce,
Can you confirm when do we need the spec? Thanks!
Flags: needinfo?(jelee) → needinfo?(bhuang)
Adam, thank you for your contribution!

We will allocate the UX resource first. You can browse the code and write a prototype before the UX spec is ready. Feel free to let the mentor know if you encounter any problem.
Jenny, there's no hard deadline here so it does depend on when you are available (and when Adam is available to work on it).
That said I think it's one of the higher priority items in WiFi settings vs all the other requests as it stops some users from connecting to certain networks.
Flags: needinfo?(bhuang)
blocking-b2g: backlog → ---
See Also: → 1123685
Keywords: feature, foxfood
@Harly please keep this in UX backlog to provide spec
Flags: needinfo?(hhsu)
Hi, In this draft spec, I have added the IP setting slector in the wifi setting page. Users can tap on it to change the DHCP and Static IP address, if you have any questions or concerns, please let me know, thanks.
Flags: needinfo?(hhsu)
(In reply to Evan Hsu from comment #23)
> Created attachment 8659102 [details]
> [Bug 849703] Wi-Fi - Static IP Adress Draft.pdf

I see in WebAPI

https://developer.mozilla.org/en-US/docs/Web/API/WifiManager/setStaticIpMode

The function is supported to set proxy http, maybe is useful to add in this draft spec a option to set proxy server like the image attached.

Actually I used proxy server across set prefs in WebIDE but that is bored, this feature is very important for me, I would like help this bug if is needed.
Pochy, yeah we are welcome any help to move it forward. Ping me if you need any help to implement this spec
Mentor: eragonj+moz → gasolin
Sure, I would like to help in implement this feature, also because in this API is supported for proxy server, this proxy is of type PAC?, I mean if this is supported a chain like http://user:pass@nameserver:port ?
Tim, do you know the API detail or help check if API still works?
Flags: needinfo?(tihuang)
For setting static IP address of WiFi, it should use setStaticIpMode[1]. And the API detail has been described in this document. However, the proxy could be only used in IP address, the PAC format is not supported. And following is an example of the 'param' of setStaticIpMode:

const STATIC_IP_CONFIG = {
  enabled: true,
  ipaddr: "192.168.111.222",
  proxy: "",
  maskLength: 24,
  gateway: "192.168.111.1",
  dns1: "8.8.8.8",
  dns2: "8.8.4.4",
};

[1] https://developer.mozilla.org/en-US/docs/Web/API/WifiManager/setStaticIpMode
Flags: needinfo?(tihuang)
ooh, Thanks TIM for the answer, when I check this API, the part of the proxy is not clear for me, when you say

> the proxy could be only used in IP address

This means that in this part of the function is a string or something like 10.0.0.1:8080 (address:port)? or what proxy type you refer in this, I thinking in the pref "network.proxy.type" [1] or this is no related?

How can be complicated is write support for PAC format?, I would like help in this too, because I need proxy with username and password in my regular connection to internet.

I think here are two features important for version 2.6 at least to me :-)

[1] https://developer.mozilla.org/en-US/docs/Mozilla/Preferences/Mozilla_networking_preferences#Proxy
Hi pochy, we are during Chinese New Year's holiday (until next monday), please be patient if you really need help to proceed. Or you can just try it:)
Flags: needinfo?(tihuang)
First of all, I have to apologize regarding my previous comment because the information I gave is not fully correct. The 'proxy' in the static IP setting has no function at all. The static IP setting only sets the static IP and ignores the 'proxy' setting. However, there is an API, setHttpProxy[1], for setting the http proxy. You could use 'setHttpProxy' to set the proxy, but it still doesn't support the PAC format.

Fortunately, the Gecko does support the PAC format, but the implementation in the B2G doesn't support PAC right now. However, If you could access following two preferences, I think the PAC should work fine:

"network.proxy.autoconfig_url" : Write your PAC here.
"network.proxy.type"           : Set to PROXY_TYPE_PAC(2)

Although, I do not think the Gaia is capable of modifying preferences, so It must has a new API for doing this job.

[1] https://dxr.mozilla.org/mozilla-central/source/dom/webidl/MozWifiManager.webidl#234
Flags: needinfo?(tihuang)
Assignee: adam.fonagy → nobody
Mentor: gasolin
Status: ASSIGNED → NEW
Flags: needinfo?(adam.fonagy)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.