The folder pane no longer shows the folder specific icons (depending on folder properties), with Extra Folder Columns and Junquilla

VERIFIED INVALID

Status

VERIFIED INVALID
6 years ago
5 years ago

People

(Reporter: aceman, Assigned: aceman)

Tracking

({regression})

22 Branch
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon:Extra Folder Columns][addon:junquilla])

Attachments

(2 attachments)

(Assignee)

Description

6 years ago
Created attachment 723371 [details]
screenshot

After fix for bug 407956 the folder pane no longer has the folder specific icons. All folders are shown with the generic folder icon. See the attachment.

I noticed the problem while developing the patch for bug 407956 on my dev linux machine which I noted in the bug. Now I see the problem also on an independent Win XP machine with an official nightly build.

I am not sure we did something wrong in the patch, or if the applying of style (icons) on the folders via properties should be updated in some way.

Does Seamonkey see the problem too?
There were some mentions of this in the Calendar newsgroup, so it seems you are not alone. I don't recall seeing this on mac, so it might be platform specific.
On my machine I see no problem.

The screenshot looks like you are using Extra Folder Columns. Can you test with disabling it.

Maybe this add-on is also affected by bug 407956
(Assignee)

Comment 3

6 years ago
Wow, you are right. Disabling it fixes it. I also have it in my dev profile...
(Assignee)

Comment 4

6 years ago
Standard8, I've sent you a modified version of Extra Folder Columns in the past. Have you looked at it? Can I fix this bug on top of the modifications there or do you not agree with them?
Flags: needinfo?(mbanner)
(Assignee)

Comment 5

6 years ago
Created attachment 723511 [details]
updated extension

Extension fixes should probably be done in some other place, but I upload the fixed version here for reference if anybody wants to try it out.
This is the version I sent you on 2012-06-26 plus the fix for the bug here (update to removal of properties array).

Warning, the addon works only in the en-US locale as I added some new strings that are not yet in the other locales. They fix problems and features requested in the comments to the addon on addons.mozilla.org. I've been running with this modified version for about a year now with no problems (the one here is not caused by my modifications:)).
Assignee: nobody → acelists
Status: NEW → ASSIGNED
Attachment #723511 - Flags: feedback?(mbanner)
(Assignee)

Updated

6 years ago
Severity: major → minor
Whiteboard: [workaround: disable the "Extra folder columns" addon, or try the one attached here]
(Assignee)

Comment 6

6 years ago
The fix is not 100% right, the extensions still causes stripes (alternating rows of different color) in the folder pane.

Comment 7

6 years ago
junquilla in my case.

not just no special icons - folder bolding, indicating new messages, is also gone.
Severity: minor → normal
(In reply to Wayne Mery (:wsmwk) from comment #7)
> junquilla in my case.
> 
> not just no special icons - folder bolding, indicating new messages, is also
> gone.

Hm, this sounds like this extension is having a similar problem to what is tracked in bug 848265 for the ChatZilla extension.
See Also: → bug 848265
Ok, I've uploaded a new version of the add-on that copes with old & new versions of the API. I'll take a look at the other suggested changes sometime soon.

Marking this as works for me as it wasn't a Thunderbird bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(mbanner)
Resolution: --- → WORKSFORME
Attachment #723511 - Flags: feedback?(mbanner)
(Assignee)

Updated

6 years ago
Status: RESOLVED → VERIFIED
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: [workaround: disable the "Extra folder columns" addon, or try the one attached here]

Comment 10

5 years ago
Just encountered this myself after an upgrade to 24b2. Problematic extension for me was:

Remove Duplicate Messages (Alternate) 0.3.7

Updated

5 years ago
Resolution: WORKSFORME → INVALID
Whiteboard: [addon:Extra Folder Columns]

Comment 11

5 years ago
I also get this with junquilla 1.0.2
Whiteboard: [addon:Extra Folder Columns] → [addon:Extra Folder Columns][addon:junquilla]

Comment 12

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #11)
> I also get this with junquilla 1.0.2

I also get this with Tasks & Mail 2.3.1
Summary: The folder pane no longer shows the folder specific icons (depending on folder properties). → The folder pane no longer shows the folder specific icons (depending on folder properties), with Extra Folder Columns and Junquilla
You need to log in before you can comment on or make changes to this bug.