[B2G][Contacts][Favorite]: Newly added favorite contacts are duplicating when the contacts order list changed by the last name.

VERIFIED DUPLICATE of bug 852765

Status

VERIFIED DUPLICATE of bug 852765
6 years ago
5 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: future dup)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 723683 [details]
bug3.11.13

Description:
The contacts duplicate themselves, if they just have been added to the Favorite list and then ordered by the last name.

Repro Steps:
1) Updated to Unagi Build ID: 20130311095652
2) Open Contact application
3) Choose any contacts and add them as Favorite
4) Go back to the contact list and verify the new favorite contact added.
5) Open "Contacts Settings" and tap "Order by the last name"

Expected:
All contacts order changed by the last name

Actual:
Newly added favorite contacts are duplicating and not ordered by the last name.

Repro frequency:
100% 


Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a56593f84577
Gaia: 69cfb9f7d00e5ee7886e40645240686091b6b57e

Notes:
Q Analysts Test Team Priority Rating: ( Pri 2)
See the attachment
This issue reproduces only with newly added favorites contacts from the existing or imported Facebook contact list.
(Reporter)

Updated

6 years ago
Summary: [B2G][Contacts][Favorite]: Newly added favorite contacts are dublicating when the contacts order list changed by the last name. → [B2G][Contacts][Favorite]: Newly added favorite contacts are duplicating when the contacts order list changed by the last name.
duplication is bad.  It duplicates the favorite and the contact info...
This is with a flashed version of 2013 03 15 as well.  Noming.
blocking-b2g: --- → leo?
Is this a recent regression?
blocking-b2g: leo? → leo+

Comment 3

6 years ago
Although it doesn't seem related, it does. Uplifting that bug will fix this one.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 852765

Updated

6 years ago
Whiteboard: future dup
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.