If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Valgrind on tbpl detects leak - 128 bytes are definitely lost (direct) with js::SCOutput::write on the stack

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
major
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: gkw, Unassigned)

Tracking

(Blocks: 1 bug, {mlk, regression, valgrind})

Trunk
All
Linux
mlk, regression, valgrind
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 723819 [details]
stack

Valgrind detects a leak of 128 bytes (direct) with js::SCOutput::write on the stack, see attached snippet which comes from:

https://tbpl.mozilla.org/php/getParsedLog.php?id=20552379&tree=Firefox&full=1

Due to bustage in bug 844387, the regression window is a little large:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d57a813c77a4&tochange=eccf45749400
(Reporter)

Comment 1

5 years ago
Suppressed in https://hg.mozilla.org/mozilla-central/rev/619f2df16dfe
(Reporter)

Comment 2

5 years ago
Also suppressed for 64-bit builds in https://hg.mozilla.org/mozilla-central/rev/9df484a3fe56
Hardware: x86 → All
This is no longer occurring in Valgrind-on-TBPL runs.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.