Intermittent dom/tests/mochitest/ajax/offline/test_identicalManifest.html (and others) | Assertion count is greater than expected range (op == PL_DHASH_LOOKUP || RECURSION_LEVEL(table) == 0, RECURSION_LEVEL(table) != IMMUTABLE_RECURSION_LEVEL)

RESOLVED DUPLICATE of bug 877562

Status

()

Core
Networking: Cache
RESOLVED DUPLICATE of bug 877562
5 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({assertion, intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=20562343&tree=Mozilla-Inbound&full=1

Rev3 WINNT 6.1 mozilla-inbound debug test mochitest-3 on 2013-03-12 05:00:12 PDT for push 80e584c6ac74
slave: talos-r3-w7-014

05:07:32     INFO -  3803 INFO TEST-PASS | /tests/dom/tests/mochitest/ajax/offline/test_overlap.html | Should have fallen back.
05:07:32     INFO -  ###!!! ASSERTION: op == PL_DHASH_LOOKUP || RECURSION_LEVEL(table) == 0: 'op == PL_DHASH_LOOKUP || RECURSION_LEVEL(table) == 0', file e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/obj-firefox/xpcom/build/pldhash.cpp, line 575
05:07:32     INFO -  xul!webrtc::ViEFileObserver::operator=+0x000000000013D7DA
05:07:32     INFO -  xul!webrtc::ViEFileObserver::operator=+0x000000000014124A
05:07:32     INFO -  xul!webrtc::ViEFileObserver::operator=+0x000000000014243B
05:07:32     INFO -  xul!webrtc::ViEFileObserver::operator=+0x00000000018812E1
05:07:32     INFO -  xul!webrtc::ViEFileObserver::operator=+0x00000000018273A8
05:07:32     INFO -  xul!webrtc::ViEFileObserver::operator=+0x000000000188087F
05:07:32     INFO -  nspr4!PRP_TryLock+0x000000000000061B
05:07:32     INFO -  MSVCR100D!beginthreadex+0x00000000000001D4
05:07:32     INFO -  kernel32!BaseThreadInitThunk+0x0000000000000012
05:07:32     INFO -  ntdll!RtlInitializeExceptionChain+0x0000000000000063
05:07:32     INFO -  ntdll!RtlInitializeExceptionChain+0x0000000000000036
05:07:32     INFO -  ###!!! ASSERTION: RECURSION_LEVEL(table) != IMMUTABLE_RECURSION_LEVEL: 'RECURSION_LEVEL(table) != IMMUTABLE_RECURSION_LEVEL', file e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/obj-firefox/xpcom/build/pldhash.cpp, line 681
05:07:32     INFO -  3804 INFO TEST-END | /tests/dom/tests/mochitest/ajax/offline/test_overlap.html | finished in 1088ms
05:07:32     INFO -  ++DOMWINDOW == 75 (1A317BE0) [serial = 1093] [outer = 0D6E83B8]
05:07:32     INFO -  3805 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/offline/test_overlap.html | Assertion count 3 is greater than expected range 0-0 assertions.
(Reporter)

Comment 1

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=20605374&tree=Mozilla-Inbound
(Reporter)

Updated

5 years ago
Summary: Intermittent dom/tests/mochitest/ajax/offline/test_{assorted} | Assertion count is greater than expected range (op == PL_DHASH_LOOKUP || RECURSION_LEVEL(table) == 0, RECURSION_LEVEL(table) != IMMUTABLE_RECURSION_LEVEL) → Intermittent dom/tests/mochitest/ajax/offline/test_identicalManifest.html (and others) | Assertion count is greater than expected range (op == PL_DHASH_LOOKUP || RECURSION_LEVEL(table) == 0, RECURSION_LEVEL(table) != IMMUTABLE_RECURSION_LEVEL)
Comment hidden (Treeherder Robot)
So the problem is that we're touching mActiveCachesByGroup on multiple threads with no locking.
Component: DOM → Networking: Cache
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Probably a dupe of Bug 877562
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 877562
You need to log in before you can comment on or make changes to this bug.