Closed Bug 877562 Opened 7 years ago Closed 7 years ago

Intermittent test_identicalManifest.html| application crashed [@ PL_DHashTableOperate] after "Assertion failure: op == PL_DHASH_LOOKUP || (*(uint32_t*)(table->entryStore + ((uint32_t)1 << (32 - (table)->hashShift)) * table->entrySize)) == 0"

Categories

(Core :: Preferences: Backend, defect)

x86
Windows 8
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla26
Tracking Status
firefox24 --- fixed
firefox25 --- fixed
firefox26 --- fixed

People

(Reporter: jesup, Assigned: mayhemer)

References

Details

(Keywords: assertion, crash, intermittent-failure)

Crash Data

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #864705 +++

+++ This bug was initially created as a clone of Bug #859744 +++

+++ This bug was initially created as a clone of Bug #859414 +++

Out of room in summary. 

https://tbpl.mozilla.org/php/getParsedLog.php?id=23554109&tree=Mozilla-Beta&full=1

16:13:10 INFO - Assertion failure: op == PL_DHASH_LOOKUP || (*(uint32_t*)(table->entryStore + ((uint32_t)1 << (32 - (table)->hashShift)) * table->entrySize)) == 0, at e:/builds/moz2_slave/m-beta-w32-d-00000000000000000/build/obj-firefox/xpcom/build/pldhash.cpp:573
16:13:13 WARNING - TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/ajax/offline/test_identicalManifest.html | Exited with code -2147483645 during test run
The hash table is accessed on multiple thread w/o a mutex.

I'll fix it.
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
Attached patch v1Splinter Review
Try is green, I think we have a fix.
Attachment #790157 - Flags: review?(jduell.mcbugs)
Attachment #790157 - Flags: review?(jduell.mcbugs) → review+
https://hg.mozilla.org/mozilla-central/rev/067bc81b7074
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Can you please request approval for uplift to aurora/beta?
Flags: needinfo?(honzab.moz)
Comment on attachment 790157 [details] [diff] [review]
v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): since ever
User impact if declined: concurrent thread memory access (hashtable operations) causing heap corruption leading to unpredictable crashes
Testing completed (on m-c, etc.): just landed on m-c
Risk to taking this patch (and alternatives if risky): this adds a new lock, I took care not to call foreign code under it, still it's a new lock that might introduce a deadlock (however, IMO low probability of it)
String or IDL/UUID changes made by this patch: none
Attachment #790157 - Flags: approval-mozilla-beta?
Attachment #790157 - Flags: approval-mozilla-aurora?
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #8)
> Can you please request approval for uplift to aurora/beta?

Done
Flags: needinfo?(honzab.moz)
Attachment #790157 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Honza Bambas (:mayhemer) from comment #9)
> Comment on attachment 790157 [details] [diff] [review]
> v1
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): since ever
> User impact if declined: concurrent thread memory access (hashtable
> operations) causing heap corruption leading to unpredictable crashes
> Testing completed (on m-c, etc.): just landed on m-c
> Risk to taking this patch (and alternatives if risky): this adds a new lock,
> I took care not to call foreign code under it, still it's a new lock that
> might introduce a deadlock (however, IMO low probability of it)

Given the risk here I'll let it bake on nightly/aurora a couple of days in preparation for a beta uplift.
> String or IDL/UUID changes made by this patch: none
Attachment #790157 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 850177
You need to log in before you can comment on or make changes to this bug.