Intermittent svg/as-image/list-simple-1.html | image comparison (==), max difference: 74 (or 255, or whatever), number of differing pixels: 2 (or 10000, or 20000, or whatever)

RESOLVED FIXED in Firefox 37

Status

()

defect
P5
normal
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: RyanVM, Assigned: seth)

Tracking

({intermittent-failure})

Trunk
mozilla38
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox37 fixed, firefox38 fixed, firefox-esr31 wontfix)

Details

https://tbpl.mozilla.org/php/getParsedLog.php?id=20563510&tree=Mozilla-Inbound

Rev3 WINNT 6.1 mozilla-inbound debug test reftest on 2013-03-12 04:29:17 PDT for push 90fbe56a05b1
slave: talos-r3-w7-022

05:44:17     INFO -  REFTEST TEST-START | file:///c:/talos-slave/test/build/tests/reftest/tests/layout/reftests/svg/as-image/list-simple-1-ref.html | 6785 / 9185 (73%)
05:44:17     INFO -  ++DOMWINDOW == 612 (0C3F3AE0) [serial = 19783] [outer = 05564488]
05:44:17     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/tests/reftest/tests/layout/reftests/svg/as-image/list-simple-1.html | image comparison (==), max difference: 74, number of differing pixels: 2
05:44:17     INFO -  REFTEST   IMAGE 1 (TEST): <see log>
05:44:17     INFO -  REFTEST   IMAGE 2 (REFERENCE): <see log>
05:44:17     INFO -  REFTEST INFO | Saved log: START file:///c:/talos-slave/test/build/tests/reftest/tests/layout/reftests/svg/as-image/list-simple-1.html
05:44:17     INFO -  REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
05:44:17     INFO -  REFTEST INFO | Saved log: Initializing canvas snapshot
05:44:17     INFO -  REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
05:44:17     INFO -  REFTEST INFO | Saved log: [CONTENT] RecordResult fired
05:44:17     INFO -  REFTEST INFO | Saved log: RecordResult fired
05:44:17     INFO -  REFTEST INFO | Saved log: START file:///c:/talos-slave/test/build/tests/reftest/tests/layout/reftests/svg/as-image/list-simple-1-ref.html
05:44:17     INFO -  REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
05:44:17     INFO -  REFTEST INFO | Saved log: Initializing canvas snapshot
05:44:17     INFO -  REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
05:44:17     INFO -  REFTEST INFO | Saved log: [CONTENT] RecordResult fired
05:44:17     INFO -  REFTEST INFO | Saved log: RecordResult fired
05:44:17     INFO -  REFTEST INFO | Loading a blank page
I strongly suspect that this is your classic "DrawWindow doesn't actually SyncDecode, even though it claims to" issue. I _think_ that this will be fixed when bug 695763 lands, which is hopefully coming soon. Speculatively adding a dependency.
Depends on: 695763
Summary: Intermittent svg/as-image/list-simple-1.html | image comparison (==), max difference: 74, number of differing pixels: 2 → Intermittent svg/as-image/list-simple-1.html | image comparison (==), max difference: 74 (or 255, or whatever), number of differing pixels: 2 (or 10000, or 20000, or whatever)
Priority: -- → P5
(In reply to Seth Fowler [:seth] from comment #26)
> I strongly suspect that this is your classic "DrawWindow doesn't actually
> SyncDecode, even though it claims to" issue. I _think_ that this will be
> fixed when bug 695763 lands, which is hopefully coming soon. Speculatively
> adding a dependency.

Guess not :(. Any other ideas? :)
Flags: needinfo?(seth)
Depends on: 1091229
I expect bug 1091229 to fix this totally.
Flags: needinfo?(seth)
I suspect that this recent spike is tied to recent ImageLib landings, most of which have been backed out at this point.
Flags: needinfo?(seth)
Marked random on Windows and OS X in this push:

https://hg.mozilla.org/integration/mozilla-inbound/rev/2b6bd6b2dfb6
https://hg.mozilla.org/mozilla-central/rev/2b6bd6b2dfb6
Assignee: nobody → seth
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
My mistake, this should've been marked "leave-open".
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
(In reply to Seth Fowler [:seth] from comment #219)
> Marked random on Windows and OS X in this push:

Seth, I guess we should we mark this as random on Linux as well?  Looks like we're getting dozens of failures per day right now.  (on both linux32 & linux64 -- though it's all opt/pgo, it looks like -- not debug.)

(The fact that this just started failing so often is a bit worrying... I wonder if it means users will now be more likely to hit real-world versions of this bug, with raster list-images failing to load.)