Clearing download history on shutdown doesn't remove download history but Clearing browsing history does

RESOLVED DUPLICATE of bug 847627

Status

()

defect
RESOLVED DUPLICATE of bug 847627
7 years ago
6 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({regression})

20 Branch
Points:
---

Firefox Tracking Flags

(firefox19 unaffected, firefox20 affected, firefox21 affected, firefox22 affected)

Details

If you set Clear download history on shutdown, your download history is not removed on shutdown.
On the contrary, if you only set Clear browsing history on shutdown, your browsing and download history is removed on shutdown.
working as expected, the option is bogus though
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 847627
Not tracking as the dup for this bug 847627 is on our radar.
Bug 847627 is the long term solution but it requires both UI and string changes which is too late for Beta and maybe Aurora while this bug doesn't so I am reopening it.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
There's nothing we can do in Beta or Aurora, the logic in the dialog is just flawed.
Or better, at a maximum we could hide the option completely on branches.
(In reply to Marco Bonardo [:mak] from comment #5)
> Or better, at a maximum we could hide the option completely on branches.
If you hide Download History (browser ⊃ chrome ⊃ browser ⊃ sanitize.dtd ⊃ itemDownloadHistory.label) in Settings for Clearing History, checking Browsing History (browser ⊃ chrome ⊃ browser ⊃ sanitize.dtd ⊃ itemBrowsingHistory.label) will clear both Browsing & Download History (browser ⊃ chrome ⊃ browser ⊃ sanitize.dtd ⊃ itemHistoryAndDownloads.label) which is still misleading.

As a workaround for branches, you could use the Browsing & Download History label of Privacy panel for the Settings for Clearing History window but I don't guarantee the right formatting especially for some verbose locales.
fwiw, I still think this is a duplicate of bug 847627, that will also take care of branches with different solutions. Do you think this bug still has something to handle apart from that?
Flags: needinfo?(scoobidiver)
(In reply to Marco Bonardo [:mak] from comment #7)
> fwiw, I still think this is a duplicate of bug 847627, that will also take
> care of branches with different solutions. Do you think this bug still has
> something to handle apart from that?
No.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
No longer depends on: 847627
Flags: needinfo?(scoobidiver)
Resolution: --- → DUPLICATE
Duplicate of bug: 847627
Duplicate of this bug: 867660
You need to log in before you can comment on or make changes to this bug.