Downloads are not cleared when browser closes.

RESOLVED DUPLICATE of bug 850207

Status

()

Firefox
Downloads Panel
RESOLVED DUPLICATE of bug 850207
5 years ago
5 years ago

People

(Reporter: d-man97, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

Options > Privacy > Custom > Clear history when Firefox closes > Settings
Check download history.
Close options.
Download something.
Download icon (in my add-on bar) turns green and shows file when clicked.
Close Firefox.
Open Firefox.
Click Downloads icon (which is grey now) and it will bring up an empty list, as expected.
Click Show All Downloads (Ctrl-J)


Actual results:

Downloaded file is listed. It was not cleared.


Expected results:

Download history should have been cleared.
I'm not able to reproduce this on Windows 7, User agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0, Build ID: 20130409194949

Does this bug happen in safe mode? (Help -> Restart with add-ons disabled and then confirm when a dialog asking if you want to restart in safe mode appears)

If yes, could you also try with a clean profile? (See here: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles)

When you will have done this, please report the results in a comment, thanks.
Component: Untriaged → Downloads Panel
Flags: needinfo?(d-man97)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 850207
(Reporter)

Updated

5 years ago
Flags: needinfo?(d-man97)
You need to log in before you can comment on or make changes to this bug.