Private browsing downloads not cleared when last private tab is closed

VERIFIED FIXED in Firefox 20

Status

()

defect
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: bnicholson, Assigned: bnicholson)

Tracking

unspecified
Firefox 22
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20+ verified, firefox21+ verified, firefox22 verified)

Details

Attachments

(1 attachment)

Bug 823285 fixes the problem where Fennec is killed while private downloads are in progress, but it doesn't fix the case where the last private context is closed while Fennec is running. For that, we should iterate through the list of active downloads and clear the notifications on last-pb-context-exited.

From https://bugzilla.mozilla.org/show_bug.cgi?id=823285#c0:

STR:
1) Open a private tab and start a download
2) Close the private tab

The download remains in the Android notifications list, stuck at whatever % it was when the private tab was closed. Even worse, clicking it does nothing, and it stays in the notification bar without any way to get rid of it (even clearing the X to close all notifications doesn't work).
Assignee

Updated

6 years ago
Blocks: 823285
Assignee

Comment 1

6 years ago
This keeps track of all all private downloads and cancels their notifications when the last private context is closed.
Attachment #724182 - Flags: review?(wjohnston)
Assignee

Comment 2

6 years ago
This bug is the low risk, second part of the "notifications get stuck" fix for private browsing (see comment 0).
Assignee

Comment 3

6 years ago
Comment on attachment 724182 [details] [diff] [review]
Clear private download notifications on last-pb-context-exited

Preliminary request assuming this patch is r+'ed and lands without issue.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 582244 (pb)
User impact if declined: closing the last private tab during a download will make all in-progress downloads freeze with no way to remove their notifications
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #724182 - Flags: approval-mozilla-beta?
Attachment #724182 - Flags: approval-mozilla-aurora?
Assignee

Updated

6 years ago
Attachment #724182 - Flags: review?(mark.finkle)
Comment on attachment 724182 [details] [diff] [review]
Clear private download notifications on last-pb-context-exited

Looks OK
Attachment #724182 - Flags: review?(mark.finkle) → review+
Assignee

Updated

6 years ago
Attachment #724182 - Flags: review?(wjohnston)
https://hg.mozilla.org/mozilla-central/rev/9f33c23b3b77
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Status: RESOLVED → VERIFIED
Comment on attachment 724182 [details] [diff] [review]
Clear private download notifications on last-pb-context-exited

Approving the low risk uplift of a corner case missed by Bug 823285 (already in beta, aurora) when clearing private browsing downloads which is a new feature in Fx20.

Please make sure to land by 3/18 for it to make it to next beta.
Attachment #724182 - Flags: approval-mozilla-beta?
Attachment #724182 - Flags: approval-mozilla-beta+
Attachment #724182 - Flags: approval-mozilla-aurora?
Attachment #724182 - Flags: approval-mozilla-aurora+

Comment 10

6 years ago
Verified fixed on:
-build: Firefox for Android 20.0b6 (2013-03-21)
-device: Samsung Galaxy Nexus
-OS: Android 4.1.1
Depends on: 868604

Comment 11

6 years ago
Verified on Firefox for Android 21.0b7 using: Nexus 4 (4.2.2)
You need to log in before you can comment on or make changes to this bug.