Closed Bug 850673 Opened 7 years ago Closed 7 years ago

Defect - Double clicking Next in Find bar selects and displays grippers for next selectable instance

Categories

(Firefox for Metro Graveyard :: Browser, defect, P1)

x86
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 22

People

(Reporter: virgil.dicu, Assigned: jimm)

References

Details

(Whiteboard: feature=defect u=metro_firefox_user c=content_features p=1)

Attachments

(1 file)

Mozilla/5.0 (Windows NT 6.2; rv:22.0) Gecko/20130312 Firefox/22.0 (http://hg.mozilla.org/mozilla-central/rev/7433bc4545c9)

Associated with bug 831940 - Find previous and next instance of text in a page

1. Launch Firefox Metro.
2. Load  https://www.mozilla.org/en-US/firefox/features/  (or any other page)
3. Invoke the find bar (right click settings and Find or Ctrl+F)
4. Type any word (e.g. "easy")
5. Double click the Next arrow.

Actual result: the grippers are displayed. 

I'm not sure if this is intended or not for tablets, but there is no use for these in Metro Desktop. Haven't found any other references for comparison.

Note: Simply selecting any word, without the Find bar will display the grippers as well.
Possibly a defect for iteration 5
Blocks: caret-sel
Flags: needinfo?(asa)
I think this depends on how much work is involved. If it's a relatively easy fix, we should get to this soon. If it's complicated, we can tackle it in v2. What say you engineers, is this a difficult problem?
Flags: needinfo?(asa)
Flags: needinfo?(jmathies)
Should be pretty easy to fix. When enabled the find bar should disable the SelectionHelperUI.
Flags: needinfo?(jmathies)
Blocks: metrov1it5
No longer blocks: metrov1triage
Priority: -- → P1
Summary: Double clicking Next in Find bar selects and displays grippers for next selectable instance → Defect - Double clicking Next in Find bar selects and displays grippers for next selectable instance
Whiteboard: feature=defect u=metro_firefox_user c=content_features p=tbd
Assignee: nobody → jmathies
Whiteboard: feature=defect u=metro_firefox_user c=content_features p=tbd → feature=defect u=metro_firefox_user c=content_features p=2
Attached patch fixSplinter Review
Comment on attachment 730629 [details] [diff] [review]
fix

really simple patch.
Attachment #730629 - Flags: review?(mbrubeck)
Attachment #730629 - Flags: review?(mbrubeck) → review+
Whiteboard: feature=defect u=metro_firefox_user c=content_features p=2 → feature=defect u=metro_firefox_user c=content_features p=1
Status: NEW → ASSIGNED
QA Contact: jbecerra
https://hg.mozilla.org/mozilla-central/rev/1e42f4a23d30
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
OS: Windows 8 → Windows 8 Metro
Version: 22 Branch → Trunk
Flags: needinfo?(jbecerra)
Mozilla/5.0 (Windows NT 6.2; rv:23.0) Gecko/20130404 Firefox/23.0

Verified using steps in comment 0. One can double click fast enough and Nightly will now return corresponding results without grippers.

One adjacent question, though: selecting text in a normal page will display grippers while using Metro desktop. Is this intended?
I haven't seen this called out in any story.
Status: RESOLVED → VERIFIED
I think that's a bug but will let Jim confirm
(In reply to Virgil Dicu [:virgil] [QA] from comment #8)
> One adjacent question, though: selecting text in a normal page will display
> grippers while using Metro desktop. Is this intended?
> I haven't seen this called out in any story.

It's a bug if you can reproduce it using the mouse in metro land. running the metro
interface on desktop isn't an official product which we maintain.
I've seen this in metro as well in Immersive mode but I don't have exact steps.
Flags: needinfo?(jbecerra)
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130825030201
Built from http://hg.mozilla.org/mozilla-central/rev/01576441bdc6

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in comment0 and got expected result.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.