Closed Bug 851003 Opened 7 years ago Closed 6 years ago

Deleting an account while syncing results in calendar deletion, but events in the UI sometimes get left behind

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:leo+, b2g18+ verified, b2g-v1.1hd fixed)

RESOLVED FIXED
blocking-b2g leo+
Tracking Status
b2g18 + verified
b2g-v1.1hd --- fixed

People

(Reporter: leo.bugzilla.gaia, Assigned: gaye)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

1. Title : Edited event from external account not deleted when removing the account from calendar application
2. Precondition : 
3. Tester's Action : 
   a) Add a google account to calendar with events added.
   b) Edit an event which is added in google account and save the event.
   c) Remove the google account where event was edited.

4. Detailed Symptom (ENG.) : 
   a) The edited event which was present in external google account will be 
      still present in offline calendar.
   b) On clicking the event in the offline calendar, detail view will be opened 
      without any values in the fields.
5. Gaia Version : 
6. Expected : The event which was present in the google account should not be 
   available in the offline calendar.
7. Reproducibility: 100%
This might be similar to bug 809607.
blocking-b2g: --- → leo?
qawanted to find out whether these events can still be deleted after removing the account, if the user finds this behavior frustrating.
blocking-b2g: leo? → -
tracking-b2g18: --- → +
Keywords: qawanted
QA Contact: jsmith
Confirmed. Can't delete the events either. Renom.
blocking-b2g: - → leo?
Keywords: qawanted
Keywords: regression
blocking-b2g: leo? → leo+
Assignee: nobody → gasolin
learned Calendar App structure and start tracing the bug
found I can't reproduce this issue anymore in today's gaia-master c580c47da1f7cc421c7aa586b177f7dab881baae (Merge pull request #9426 from evanxd/bug-855814).

Wondering if its bug 816610(Don't block when loading (idb) stores), which was not uplift to v1-train. So I checkout v1-train and can't reproduce this issue either.

Is there any bugfix that already solved this issue?
Flags: needinfo?(jlal)
FYI bug 867747's regression let google calendar can't be deleted in 2013/5/3 code, thus I test with the version described in comment 5.
As note above, the bug was there several weeks ago. but now it can't be reproduced (even in 2013/5/8 master-gaia), so I think this issue was gone.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
I have reproduced this on latest v1-train(a4e86b2aeed3eaedea684edb4981fae69a6fa2df). Please check again.
Status: RESOLVED → REOPENED
Flags: needinfo?(gasolin)
Resolution: WORKSFORME → ---
I can't reproduce this in 2013/5/10 pvt build for leo
(In reply to Walter Chen from comment #9)
> I can't reproduce this in 2013/5/10 pvt build for leo

Hmm okay. Let me take a look as well.
Keywords: qawanted
This issue still reproduces on Leo and Unagi devices.
The Google calendar edited event still presents in the offline calendar after deleting the Google account and in the edit mode a user is not able to delete the event, the "Remove" button doesn't response.

Environmental  Variables:
Leo Build ID: 20130510070207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/2aba3b5ac1c2
Gaia: fcaa90923894211c19b3544b5cb16eb0db5a6286

Environmental  Variables:
Unagi Build ID: 20130510070207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/2aba3b5ac1c2
Gaia: fcaa90923894211c19b3544b5cb16eb0db5a6286
Keywords: qawanted
Keep in mind this is all based on a race condition between syncing an account and deleting it (or it was in the past). I think we have a semi-complete patch for this somewhere and this bug is probably a dupe.
Flags: needinfo?(jlal)
Summary: [calendar] Edited event from external account not deleted when removing the account from calendar application → [calendar] Ensure sync transactions are aborted when
James, Thanks for clarify. I'll move to another issue.
Flags: needinfo?(gasolin)
Summary: [calendar] Ensure sync transactions are aborted when → [calendar] Ensure sync transactions are aborted when removing the account from calendar application
Assignee: gasolin → nobody
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 809607
Hi jason,

I tried the patch uploaded for bug 809607, but this issue could be still reproduced. Also i have strong belief that these two issues could be different.
Flags: needinfo?(jsmith)
(In reply to Leo from comment #15)
> Hi jason,
> 
> I tried the patch uploaded for bug 809607, but this issue could be still
> reproduced. Also i have strong belief that these two issues could be
> different.

James - Any thoughts?
Flags: needinfo?(jsmith)
Flags: needinfo?(jlal)
Assignee: nobody → gaye
Status: RESOLVED → REOPENED
Flags: needinfo?(jlal)
Resolution: DUPLICATE → ---
Talked with James - this is indeed different than the dupe.
I made this fairly confusing by attempting to make one a duplicate of another... Attempting to make it clearer and also indicate which bug is fixed.
Summary: [calendar] Ensure sync transactions are aborted when removing the account from calendar application → Deleting an account while syncing results in calendar deletion, but events in the UI sometimes get left behind
Attachment #759609 - Flags: review?(jlal)
Comment on attachment 759609 [details]
Pointer to Pull Request

><html>
><head>
><meta http-equiv="refresh" content="0; url=https://github.com/mozilla-b2g/gaia/pull/10232/files#attch-to-bugzilla">
></head>
><body>
></body>
></html>
Attachment #759609 - Attachment mime type: text/plain → text/html
Comment on attachment 759609 [details]
Pointer to Pull Request

per our irc discussion there is some perf related changes that need to be made... Please flag me again after.
Attachment #759609 - Flags: review?(jlal)
Attachment #759609 - Flags: review?(jlal)
Comment on attachment 759609 [details]
Pointer to Pull Request

works well for me-

I tested two cases:

from v1.0.1 (with the dead events and no account) to this branch
and from v1.0.1 (without dead events with account) to this branch.
Attachment #759609 - Flags: review?(jlal) → review+
Landed on master!! c7e704906372d397d26b7985866a1551d1650c1d
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Keywords: verifyme
Uplifted c7e704906372d397d26b7985866a1551d1650c1d to:
v1-train: b9725787376bb879c38514cedbdc66903f5d64bc
lgtm - I'm seeing the events I've created edited on an imported google calendar deleted cleanly when we delete the account.
1.1hd: b9725787376bb879c38514cedbdc66903f5d64bc
Flags: in-moztrap?
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.