Thunderbird automatically creates an empty unread message from 1970

RESOLVED DUPLICATE of bug 209501

Status

defect
RESOLVED DUPLICATE of bug 209501
6 years ago
2 years ago

People

(Reporter: goce.mitevski, Unassigned)

Tracking

17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupeme?)

(Reporter)

Description

6 years ago
Thunderbird creates an unread message with empty subject dating from 01.01.1970 01:00, while changing the status (read/unread) of the last message in the message list. As this message is created as a new one, it is always counted as an unread in a certain inbox. This message is always the first in the message list (for ascending order) and cannot be deleted.

The message content changes when the message is recreated, but I cannot confirm the circumstances under which this happens.

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 1

6 years ago
Once the message has been marked as read and Thunderbird is restarted, the message disappears.

Btw, I have just tried to recreate the behavior but had no success. There's probably something else that should be done... I will provide more details shortly.
(Reporter)

Comment 2

6 years ago
This is probably related to: https://bugzilla.mozilla.org/show_bug.cgi?id=209501, though the message creation time is different.

Comment 3

6 years ago
Likely dupe of bug 209501, where the date represents 1970/01/01 00:00:00 UTC. Thus, if your timezone is +0100, you will see 1970/01/01 01:00:00 instead (the 1969/12/31 stamps appear in western-hemisphere time zones).
Whiteboard: dupeme?

Comment 4

6 years ago
Can you backup your mail storage (e.g. using Windows explorer copy the folder set in the account settings -> server settings -> local directory to some safe place) and then try right-clicking the folder -> properties -> repair ?
(Reporter)

Comment 5

6 years ago
Thanks :aceman. Let's see, for a few days if that makes any difference...
(Reporter)

Comment 6

6 years ago
I can now confirm that repairing the local directory didn't make any difference. I still get the ghost message.
(In reply to Goce Mitevski from comment #6)
> I can now confirm that repairing the local directory didn't make any
> difference. I still get the ghost message.

Does this mean it is not a duplicate?
Flags: needinfo?(goce.mitevski)
Flags: needinfo?(acelists)
(Reporter)

Comment 8

6 years ago
I'm not sure.

This is still happening even in the latest version of Thunderbird 17.0.8. I can also confirm getting more than one ghost message.

Repairing the local directory makes a difference, but only until a new message arrives. Then everything is reverted and ghost messages start to appear.
Flags: needinfo?(goce.mitevski)
Flags: needinfo?(acelists)

Comment 9

5 years ago
This is still in issue in Thunderbird 33.0.2 using Arch Linux and Windows.

It is also happening when you delete many email at once or at least very fast.
Almost all bugs for "phantom mails" looks to have been closed as dup of bug 209501. So, close this bug as dup of bug 209501.
If duping is wrong, please reopen this bug with attaching sufficient data for problem analysis.

It looks for me that two kinds of "phantom mail" exists.
1. Generated upon "move mails=copy mails + remove mails" or "delete mails = move to trash = copy to trash + remove mail".
   In this case, "multiple move/delete requests happened on a folder/message at same time" seems required condition.
2. Garbage of msgDBHdr is somehow generated in msgDB, and is exposed as "phantom mail" by Compact Folder.
   It looks for me : if "filter move upon new mail download" is relevant, it tends to fall back into this case.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 209501
You need to log in before you can comment on or make changes to this bug.