Private Browsing is not enabled after selecting "Always use private browsing mode"

VERIFIED FIXED in Firefox 20

Status

()

Firefox
Private Browsing
--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Mitza, Assigned: jdm)

Tracking

({regression, verifyme})

Trunk
Firefox 22
All
Windows 7
regression, verifyme
Points:
---

Firefox Tracking Flags

(firefox20+ verified, firefox21+ verified, firefox22+ verified)

Details

(Whiteboard: [testday-20130315] )

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.152 Safari/537.22

Steps to reproduce:

1. Launch the browser.
2. Open the Options (Prefereces) dialog on the Privacy tab.
3. Select "Use custom settings for history" for "Firefox will:" and check the "Always use private browsing mode" checkbox.
4. Click OK on the Restart Firefox dialog that just appeared.




Actual results:

After restarting Firefox, Private Browsing mode was not enabled.


Expected results:

Restarting Firefox in Private Browsing mode.

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [testday-20130315]

Updated

5 years ago
Component: Untriaged → Private Browsing

Updated

5 years ago
Hardware: x86_64 → All

Comment 1

5 years ago
This is a Firefox 20 beta 5 regression (it doesn't reproduce on older versions). The obvious culprit is the fix for bug 842290.
Severity: normal → major
Keywords: regression

Updated

5 years ago
Blocks: 842290
(Assignee)

Comment 2

5 years ago
Hmm, can't reproduce on OS X. I'll find a Windows machine to fix this.

Comment 3

5 years ago
Reproducible on the latest beta, nightly, and aurora builds.
I confirm this is happening on my Win 7 x64 too on 20b5.
Nominating this for tracking given this is a recent regression.
status-firefox20: --- → affected
status-firefox21: --- → affected
status-firefox22: --- → affected
tracking-firefox20: --- → ?
tracking-firefox21: --- → ?
tracking-firefox22: --- → ?

Updated

5 years ago
Assignee: nobody → josh
tracking-firefox20: ? → +
tracking-firefox21: ? → +
tracking-firefox22: ? → +
(Assignee)

Comment 6

5 years ago
Created attachment 725590 [details] [diff] [review]
Delay restarting the browser until the preferences dialog elements are completely updated.
Attachment #725590 - Flags: review?(ehsan)

Comment 7

5 years ago
Comment on attachment 725590 [details] [diff] [review]
Delay restarting the browser until the preferences dialog elements are completely updated.

Review of attachment 725590 [details] [diff] [review]:
-----------------------------------------------------------------

Please just set the value of the pref to the thing we want.  Also, make this change to both privacy.js copies!
Attachment #725590 - Flags: review?(ehsan) → review-
(Assignee)

Comment 8

5 years ago
Created attachment 725600 [details] [diff] [review]
Delay restarting the browser until the preferences dialog elements are completely updated.

This worked.
Attachment #725600 - Flags: review?(ehsan)
(Assignee)

Updated

5 years ago
Attachment #725590 - Attachment is obsolete: true

Updated

5 years ago
Attachment #725600 - Flags: review?(ehsan) → review+
(Assignee)

Comment 10

5 years ago
Comment on attachment 725600 [details] [diff] [review]
Delay restarting the browser until the preferences dialog elements are completely updated.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 842290
User impact if declined: User can't enter permanent private browsing mode through one of two ways.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): No risk outside of the problem being addressed. 
String or UUID changes made by this patch: None.
Attachment #725600 - Flags: approval-mozilla-beta?
Attachment #725600 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/09bbdb7b40dd
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox22: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Mitza, can you please confirm this is fixed with tomorrow's Nightly?
Comment on attachment 725600 [details] [diff] [review]
Delay restarting the browser until the preferences dialog elements are completely updated.

Approving the low risk patch on aurora as this is a recent regression from our last beta which does not respect the user setting of enabling Private Browsing mode(always) based on STR in description.
Attachment #725600 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 725600 [details] [diff] [review]
Delay restarting the browser until the preferences dialog elements are completely updated.

Since this only addresses the problem let's get this on beta asap in order to have the fix in tomorrow's beta build and get verified there before our final beta next week.
Attachment #725600 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 17

5 years ago
It's too late now, but you pushed this with the wrong commit message!

Updated

5 years ago
status-firefox20: affected → fixed
status-firefox21: affected → fixed
(Reporter)

Comment 18

5 years ago
The issue does not reproduce anymore.
Shouldn't there be a way to warn the user that he is in PB mode When you select "Always use private browsing" mode.
Ex. When you select "New Private Window", a new window is opened and the left corner is purple.

Comment 19

5 years ago
Still reproducing on the latest Aurora build:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130318 Firefox/21.0 (20130318042013)

(verified as fixed on Nightly).
status-firefox22: fixed → verified

Comment 20

5 years ago
(In reply to comment #18)
> The issue does not reproduce anymore.

Great!

> Shouldn't there be a way to warn the user that he is in PB mode When you select
> "Always use private browsing" mode.
> Ex. When you select "New Private Window", a new window is opened and the left
> corner is purple.

Please file a different bug about that.  Thanks!
Ioana, can you please retest Aurora and Beta with builds generated on or after March 19? This didn't land on those branches until yesterday.
Keywords: verifyme

Comment 22

5 years ago
Verified as fixed on the 03/20 Aurora and Firefox 20 beta 6.
Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130320 Firefox/21.0
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
Status: RESOLVED → VERIFIED
status-firefox20: fixed → verified
status-firefox21: fixed → verified
You need to log in before you can comment on or make changes to this bug.