[layers-refactoring] texture tiling is not working properly in the gfx branch

RESOLVED FIXED

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: nical, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 725503 [details]
screenshot of and ImageLayer containing a video that is composited with the TileIterator code path.

This does not apply to mozilla-central.

Compositing a tiled TextureImage does not work properly.

On this page with a cheap android 2.3 device: http://www.808.dk/?code-html-5-video
the videos are rendered badly (see attachment)

The parts of the video element that are shuffled around correspond to tiles in the TextureImage and the tileIterator code path in ImageHost.cpp (around l75) is used.

h264 videos use the SharedRGBImage code path on this hardware with android 2.3 so it might be hard to reproduce this specific test case on other environments because most other setups use YCbCr images that don't have a tiled path.

If we use a BasicTextureImage for the video element instead of letting the gl context choose, we obtain a texture image that does not do tiling and the image video is rendered properly. I don't think forcing a non-tiled TextureImage is a good solution though.

Comment 1

6 years ago
Is it possible to add a test that will catch this? Or is this what is causing Android M2 to fail?
(Reporter)

Comment 2

6 years ago
I don't think it is the reason of the M2 crash. padenot told me there is already an open bug to add h264 video to the existing reftests that could have catched this.

In the mean time this is fixed in the gfx branch.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

6 years ago
cf. bug 832296 for h264 reftests
You need to log in before you can comment on or make changes to this bug.