window.frames["foobar"] doesn't work in non-HTML documents

RESOLVED DUPLICATE of bug 823227

Status

()

Core
DOM: Core & HTML
--
major
RESOLVED DUPLICATE of bug 823227
5 years ago
5 years ago

People

(Reporter: Philip Chee, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox22-)

Details

(Reporter)

Description

5 years ago
window.frames["foobar"] doesn't work.

STR:
Start SeaMonkey.
Open a MailNews window.
Look at the Error Console output:

Sun Mar 17 2013 23:32:45
Error: TypeError: window.frames.accountCentralPane is undefined
Source file: chrome://messenger/content/tabmail.js
Line: 893

Relevant code in tabmail.js:

    window.frames["accountCentralPane"].location.href = acctCentralPage;
tracking-firefox22: --- → ?
Keywords: regression
Summary: window.frames["foobar"] doesn't work → window.frames["foobar"] doesn't work in non-HTML documents
To be precise, it looks like it was this changeset specifically that regressed this:

http://hg.mozilla.org/mozilla-central/rev/27d4aafb847d
(and this also affects Thunderbird to the point where we can't use it unless we work around this or fix it).
Severity: normal → major
Fixing this in bug 823227.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
tracking-firefox22: ? → -
Resolution: --- → DUPLICATE
Duplicate of bug: 823227
You need to log in before you can comment on or make changes to this bug.