Closed Bug 852367 Opened 11 years ago Closed 10 years ago

Support "min-height: [-moz-]min-content"

Categories

(Core :: Layout, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 567039

People

(Reporter: dholbert, Unassigned)

References

()

Details

In CSS3 Flexbox, it's handy to be able to allow a flex item to shrink below its flex-basis, down to its min-content size, and no smaller.

The flexbox spec originally supported this use-case via the "auto" keyword for min-height & min-width, but now that keyword has been removed, partly because the generic "min-content" keyword from CSS3 Intrinsic Sizing can hypothetically be used in its place.

However, we don't yet support "min-content" as a height value (for 'height' and 'min-height').  Filing this bug to track adding support for this, at least in min-height.  The work may happen in another bug, but I'm filing this at least as a placeholder bug.  (At least one flexbox reftest depends on this behavior, now that "auto" is going away, and I'd like to just mark that test as failing for the time being, with a comment pointing to this bug.)
QA Whiteboard: = bug 852367?
See Also: → 567039
QA Whiteboard: = bug 852367? → = bug 567039?
Status: NEW → RESOLVED
Closed: 10 years ago
QA Whiteboard: = bug 567039?
Resolution: --- → DUPLICATE
See Also: 567039
You need to log in before you can comment on or make changes to this bug.