Web Audio streams enter the blocking state after their playback finishes

RESOLVED FIXED in mozilla22

Status

()

Core
Web Audio
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Away for a while, Assigned: Away for a while)

Tracking

Trunk
mozilla22
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
Created attachment 726493 [details]
MSG log

In a Web Audio test case which has a noticeable audio delay, I'm noting that the MSG is waking up with a larger and larger delay, finally at around 80ms towards the end of the log...
(Assignee)

Comment 1

5 years ago
We debugged this over IRC with roc, and it turns out the issue is that we put AudioNodeStreams in the blocking state when their playback finishes...
Summary: MediaStreamGraph's processing loop starts to pause for longer and longer times → Web Audio streams enter the blocking state after their playback finishes
(Assignee)

Updated

5 years ago
Assignee: nobody → ehsan
(Assignee)

Comment 2

5 years ago
Created attachment 726505 [details] [diff] [review]
Patch (v1)
Attachment #726505 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/a9d305be83c9
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
(Assignee)

Comment 5

5 years ago
Mass moving Web Audio bugs to the Web Audio component.  Filter on duckityduck.
Component: Video/Audio → Web Audio
You need to log in before you can comment on or make changes to this bug.