webapps calling mozApps.getSelf() the .result object is null

RESOLVED DUPLICATE of bug 806597

Status

Firefox Graveyard
Web Apps
RESOLVED DUPLICATE of bug 806597
5 years ago
2 years ago

People

(Reporter: dragonrider, Unassigned)

Tracking

19 Branch
x86_64
Windows 7

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

Attempting to install a webapp using the install code.  Tried this using Firefox on Windows 19.0.2 and the FirefoxOS simulator (pre3.0)
Followed the documentation on https://developer.mozilla.org/en-US/docs/DOM/Apps.getSelf

The code used is:
<code>
var request = window.navigator.mozApps.getSelf();
request.onsuccess = function(){
   console.log("NAME:" + request.result.manifest.name);
}
</code>


Actual results:

Both of these error out the same way.:
TypeError: request.result is null

using Firebug this is what comes back in response to mozApps.getSelf()
---------------------
error: null
onsuccess:  null
readyState: "done"
result:  null
...
---------------------

This is similar to bug 806597, which per comment in that bug by James is targeted only at Firefox for Android.  Since this is happening in both FirefoxOS simulator and Firefox desktop release 19.0.2 and I didn't find a bug report that fit, am creating a new one.


Expected results:

per the documentation:
---------------
getSelf() returns a DOMRequest object. The DOMRequest.result field contains an App object, which is a JavaScript object that describes the app. Before the operation is finished, DOMRequest.result is null.

Note: Due to Bug 806597, request.result incorrectly returns null even when an app is running on Desktop and Firefox for Android.

If the call is not successful, DOMRequest.error contains a DOMError object, which has information about the error.
------------------

As an information point, mozApps.getInstalled() does return an array with the result object in it as expected.

Updated

5 years ago
Component: Untriaged → Web Apps
QA Contact: jsmith
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 806597
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.