Closed Bug 853452 Opened 9 years ago Closed 8 years ago

Add devices to a Signature Summary matview

Categories

(Socorro :: Webapp, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kairo, Assigned: brandon)

References

Details

(Whiteboard: [qa-] [DB Changes])

At least for those products that report devices (right now, FennecAndroid, B2G, WebappRuntimMobile), we should add a list of affected devices to the Signature Summary.

We already added reporting on devices to report/list in bug 777372, so that explains where to get this information from, bug 847939 might make it easier to get to that data now, but I guess some aggregation work needs to be done here as well.
Assignee: nobody → bsavage
Depends on: 895927
Depends on: 895930
For Signature X - which devices and what percentage per device

See: https://github.com/mozilla/socorro/pull/748/files for target data

For FennecAndroid, B2G, WebappRuntimMobile:

Table should have: 
'Signature',
'Android_CPU_ABI',
'Android_Manufacturer',
'Android_Model',
'Android_Version', 
count
For reference for the week of 8/5/2013, we had about 9300 unique devices.
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/f8dd6ed2c96d8cf576c608f3131b920e81eb5794
Fixes bug 853452 Adds signature summary for Android Devices

* Added a signature_summary_devices to signature_summary update function
* Adding crontabber support for android_device table
* Added migration to add new tables

https://github.com/mozilla/socorro/commit/16a97bc79c1fb1df34aebaa73180ddb7c6283346
Merge pull request #1441 from selenamarie/bug853452-devices-sigsum

Fixes bug 853452 Adds signature summary for Android Devices
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
No UI yet! Sorry -- Brandon is working on the UI separately.
Flags: needinfo?(sdeckelmann)
Summary: Add devices to Signature Summary → Add devices to a Signature Summary matview
(In reply to Selena Deckelmann :selenamarie :selena from comment #5)
> No UI yet! Sorry -- Brandon is working on the UI separately.

Excellent! I eagerly await our army of dataz. Bumping to [qa-]
Whiteboard: [qa-]
I should have filed a separate bug for selena; my bad. Reopening until the UI is complete and dropping the qa- flag, since we will need QA on the new UI.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [qa-]
We need to open a separate bug because this change needs to ship before the UI ships.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Whiteboard: [qa-] [DB Changes]
Target Milestone: --- → 57
Duplicate of this bug: 835444
You need to log in before you can comment on or make changes to this bug.