Last Comment Bug 853463 - Download statusbar add-on continues downloading files from Normal Browsing to Private Broswing
: Download statusbar add-on continues downloading files from Normal Browsing to...
Status: RESOLVED INVALID
:
Product: Firefox
Classification: Client Software
Component: Extension Compatibility (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: pbnextensions
  Show dependency treegraph
 
Reported: 2013-03-21 08:23 PDT by Virgil Dicu [:virgil] [QA]
Modified: 2013-07-01 01:06 PDT (History)
12 users (show)
ehsan: needinfo? (akeybl)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
20+


Attachments

Description Virgil Dicu [:virgil] [QA] 2013-03-21 08:23:13 PDT
Reproducible on:
Firefox 20.0 beta 6 (20130320062118): Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20100101 Firefox/20.0
Latest Aurora (20130321042014): Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:21.0) Gecko/20130321 Firefox/21.0
Latest Nightly (20130321030940): Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:22.0) Gecko/20130321 Firefox/22.0

Add-on version 0.9.10

Steps to reproduce:
1. Open new profile and install Download Statusbar add-on from here: https://addons.mozilla.org/en-US/firefox/addon/download-statusbar/?src=hp-dl-mostpopular
2. Start downloading some large files (e.g. Ubuntu Desktop http://www.ubuntu.com/download/desktop/thank-you?release=latest&bits=32&distro=desktop&status=zeroc)
3. While files are downloading, and their status is shown with this add-on at the bottom of the page, go to Menu >Preferences >Privacy >Firefox will: Never remember history >Click Ok when asked to enter in Permanent Private Browsing

Expected result:
When in Permanent Private Browsing downloads from Normal Browsing should be stopped.

Actual result:
Downloads from Normal Browsing are still running with this add-on installed.

Notes:
Searching for a regression range.
Comment 1 Virgil Dicu [:virgil] [QA] 2013-03-22 02:26:55 PDT
Thanks Ehsan, the issue can be found also if, at step 3, while downloading, from File open a New Private Window (Ctrl/Cmd+Shift+P) 

This is of course by Bug 818732 - Switch Nightly to per-window private browsing;

Last good nightly: 2012-12-13
First bad nightly: 2012-12-14

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=edd45de440ba&tochange=b11065872128
Comment 2 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-03-25 09:46:23 PDT
Virgil, can you please try to do some outreach to the add-on developer to let him know of this bug? I'm asking for relnote since this could likely result in some negative feedback towards Firefox 20 when it's released.
Comment 3 Virgil Dicu [:virgil] [QA] 2013-03-27 06:06:11 PDT
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #2)
> Virgil, can you please try to do some outreach to the add-on developer to
> let him know of this bug? I'm asking for relnote since this could likely
> result in some negative feedback towards Firefox 20 when it's released.

Would gladly do, but can't seem to find any e-mail or feedback site. 
https://addons.mozilla.org/en-US/firefox/addon/download-statusbar/?src=userprofile
https://addons.mozilla.org/en-US/firefox/user/CorreyJacksinHughes/?src=api

CCing Jorge, who might have a solution to get in touch with the add-on developer.
Comment 4 Jorge Villalobos [:jorgev] 2013-03-29 09:37:46 PDT
All AMO developers were contacted about Firefox 20 compatibility, including the changes to Private Browsing Mode. However, this extension hasn't been updated in almost a year and a half, so it's most likely abandoned by its developer.
Comment 5 John Clark 2013-04-12 10:47:04 PDT
I'm not sure I see this as a bug. I recognise this as a feature. So the developer may have also seen it as a plus. 
Not having my downloads cut off just because I enter/exit private mode is a good thing in my eyes. I'm sure others out there see it as well. 

Also; the extension is long abandoned. I continue to use it anyway. 

This is not something Mozilla needs to deal with regardless; it's an extension and should be handled by the/a developer separately.
Comment 6 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-04-12 10:50:18 PDT
Agreed John. I'm marking this bug invalid since it's not really a Firefox bug. Anyone who wants this functionality should feel free to reach out to this add-on's developer. That said if development has been abandoned I don't expect this to get fixed anytime soon, if ever.
Comment 7 beanladen 2013-04-23 04:29:26 PDT
This is still listed in the 'Known Issues' paragraph of the "Whats new ?" release page,
shouldn't be there if it is invalid (I would also see this as a useful feature, not as a bug).
Comment 8 :Ehsan Akhgari (busy, don't ask for review please) 2013-05-14 13:18:58 PDT
(In reply to beanladen from comment #7)
> This is still listed in the 'Known Issues' paragraph of the "Whats new ?"
> release page,
> shouldn't be there if it is invalid (I would also see this as a useful
> feature, not as a bug).

Alex can you please remove this?

Note You need to log in before you can comment on or make changes to this bug.